Cadillac Owners Forum banner

1 - 20 of 46 Posts

·
Registered
2012 CTS coupe - 2014 XTS4 V Platinum
Joined
·
39 Posts
Discussion Starter #1
I am realizing that the design of the XTS V platinum is slightly flawed. The spray from the road after cleaning comes up onto the side and rear of the car. Has anyone found good mud flaps that look great yet? WeatherTech does not have for the XTS that I can find.
 

·
Registered
2013 XTS-4 Premium
Joined
·
185 Posts
Look on ebay, there is a nice set of molded 'splash guards' there for $51 (free shipping) set of 4 !
I think I will get the set myself as I have same problem with road spray and gravel.
hope this helps.
Update,
I have just ordered the $51 set, that has 'XTS' motif on the front parts. From China, of course. I'll update when they get here.
 

·
Registered
2012 CTS coupe - 2014 XTS4 V Platinum
Joined
·
39 Posts
Discussion Starter #3
I just ordered a set as well. I can't deal with the spray as soon as I clean the car the side get filthy if I encounter any road water.... Thanks.
 

·
Registered
Joined
·
780 Posts
According to the GM order guide, mud guards are going to be available on the '16 XTS - maybe these could be retrofitted to your car.
 

·
Registered
2013 XTS-4 Premium
Joined
·
185 Posts
According to the GM order guide, mud guards are going to be available on the '16 XTS - maybe these could be retrofitted to your car.
GM sets are already available through Amazon, but $84!!

----------

Gonna try these rubber ones from china.. If thEy aren't what I expect I won't screw them in, but the spray is getting ridiculous .

http://www.ebay.com/itm/141229705224
Looks pretty much the same as the ones I ordered, but $5 dearer.
 

·
Registered
2012 CTS coupe - 2014 XTS4 V Platinum
Joined
·
39 Posts
Discussion Starter #7
The amazon ones are not GM parts... They are the same as the ones on eBay... Some of the pictures are identical.. I paid $5 more to buy it now and get them quicker...⌛????
 

·
Registered
2013 XTS-4 Premium
Joined
·
185 Posts
The amazon ones are not GM parts... They are the same as the ones on eBay... Some of the pictures are identical.. I paid $5 more to buy it now and get them quicker...⌛????
You are right - my mistake! I thought I saw a GM set for XTS, but must have had a senior moment, apologies!
 

·
Registered
2012 CTS coupe - 2014 XTS4 V Platinum
Joined
·
39 Posts
Discussion Starter #9
Hope I can install without having to remove the wheel... If so.. I am due a tire rotation soon... I'll have my dealer do it..
 

·
Registered
Joined
·
1 Posts
I found a nice moulded set, pliable and look good. They fit great. Found them on Ebay, they even have the XTS moulded in on the rear guards. 10 minute install.
 

·
Registered
2012 CTS coupe - 2014 XTS4 V Platinum
Joined
·
39 Posts
Discussion Starter #12
Did you have to remove the tire/wheel? or just use and right angled driver?
 

·
Registered
2012 CTS coupe - 2014 XTS4 V Platinum
Joined
·
39 Posts
Discussion Starter #14
Will post as soon as I get them and installed... Should also have my window tint in the next 2 weeks...
 

·
Registered
2014 XTSVsport
Joined
·
31 Posts
No you dont have to remove your wheel if you know your way around tools its fairly simple. they protect from splash but not alot they are good for the price. But they are a C,B grade, you can tell their not OEM but they do the trick 80 percent
 

·
Registered
2012 CTS coupe - 2014 XTS4 V Platinum
Joined
·
39 Posts
Discussion Starter #17
image-1329473130.jpg image-733448107.jpg
They do a great job.. Well worth it... Look great too. Hard to see but the rears have XTS molded into the flap.
 

·
Registered
2011 V Wagon, 2012 V Coupe, 2013 XTS AWD
Joined
·
58 Posts
I'm not a mud flap kinda guy but I saw these on eBay and thought the car could use these and for $56 try them. Then I saw this post and was like nice these might actually fit and do something. Ordered before searching. Well just installed them and they fit great. I reused the factory hardware where I could. Easy install.



 

·
Registered
'03 & '06 CTS's (traded), '14 XTS Lux (traded), '16 CTS4 Premium 2.0T (now)
Joined
·
461 Posts
You say you used factory hardware where you could. Can you give us kind of a blow by blow on how you installed them? I've got the same set ordered and they should be here tomorrow. I'm curious how you got them on the rears without removing tires/wheels. There doesn't look like much room to work there.
 
1 - 20 of 46 Posts
Top