Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
The XM radio works intermittently - shows No Signal about half the time I start it up and seems to lose signal with the slightest overhead obstruction. The XM always is available - so I don't think it is an issue with stereo seeing XM.
Just crappy signal - is it a loose antenna wire or can the factory antennas just ware out? Signal for FM etc seems ok. Any aftermarket or later model antennas that are easy plug in that improve signal reception?
 

·
Registered
17 xt5 & Blk 05 cts-v
Joined
·
2,470 Posts
Mine did this and the only thing that fixed it was a new xm module. It was fixed under warranty.
 

·
Registered
Joined
·
49 Posts
Discussion Starter #3
The XM modal is in the trunk somewhere correct? Is it fairly simple to swap out? Can I just get the part and plug and play, or is there setup required?
Thanks
 

·
Registered
17 xt5 & Blk 05 cts-v
Joined
·
2,470 Posts
I think there is some setup. Need to call xm and tell them i think. Other than that i would think its plug in.
 

·
Registered
Joined
·
49 Posts
Discussion Starter #5
Was this a constant problem - like defective units or just an occasional thing? Reason I am asking is would a used one off e bay be worth it or should you just buy new from Cadillac?
Also curious about the actual "shark fin" antenna
. Again mine looks faded and old (my V is out of phoenix so spent many years baking in the desert sun). Can a new antenna, or one from a newer model year, improve signal etc?
Thanks again for all the info for V noob.
 

·
Registered
17 xt5 & Blk 05 cts-v
Joined
·
2,470 Posts
mine was constant. I may have only heard of one other with this same problem.
 
1 - 6 of 6 Posts
Top