Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
Registered
2007 CTS
Joined
·
4 Posts
Discussion Starter #1
whenever I select wash on my wipers it cycles far too long after the wash. Like 35-40 cycles.
Anybody else have this problem, herd of it of have a solution???
It's driving me nuts, and the windshield then becomes streaky.
help please.
Thanks to all helpful answers.
 

·
Registered
06 CTS Sport/Luxury package
Joined
·
9,803 Posts
Wow, this is a new one.

It could be as simple as the wiper motor housing. Normally when that goes bad, the wipers don't turn off. Or they randomly turn on themselves while it's nice and dry out. All the electronics that control the wipers are in the motor housing including the "time" that it continues to wipe the windshield after the wash.

Replace the wiper motor and things should be fine. http://www.ebay.com/itm/2003-2011-Cadillac-Windshield-Wiper-Motor-Cover-w-Circuit-Board-OEM-NEW-Genuine-/191526985162?pt=Motors_Car_Truck_Parts_Accessories&fits=Year:2006|Make:Cadillac|Model:CTS&hash=item2c97e5ddca&vxp=mtr

KOT
 

·
Registered
07' CTS-V | 07' Lux 3.6 Volant-Borla-Vsways | 08' CTS 3.6 DI Performance
Joined
·
969 Posts
I had the same problem more than a year ago.

It was the wiper motor cover. GM Part# 88958172

You can find it on Ebay for around $75

Shipped from GMPartsdirect it's about $79

It's attached to the bottom of the wiper motor, it will require a bit of disassembling to get to, it was a PITA when I did it but doable.
 

·
Registered
03 CTS (Dead), 06 3.6 CTS(Sold), 07 CTS-V
Joined
·
1,503 Posts
I actually just developed this problem....only mine wont spray any cleaner out...my previous wiper motor lost the slow settings and now this one has lost spraying out cleaner...guess I shouldn't have went the used route :/
 

·
Registered
2006 3.6L CTS, Hotchkis Sway Bars, FE2
Joined
·
526 Posts
Lol I remember when mine went bad. Huge bug exploded on my windshield. Going 40 down a country road with your entire front window being constantly covered in washer fluid to the point that you can't see out of it is both funny and terrifying. I saw one the other week with the same issue and couldn't help but laugh because the driver was freaking out much like I was when it happened. I may hate my car but we've had some fun moments. But yea it's most likely the wiper motor cover. It could also be the switch on the steering column but it's almost always the wiper motor cover. Check there first then report back if it fixed the issue or not.
 

·
Registered
07' CTS-V | 07' Lux 3.6 Volant-Borla-Vsways | 08' CTS 3.6 DI Performance
Joined
·
969 Posts
Well in my case back then, after I sparay my windshield my wipers keep going for a minute. No matter how long or short I kept my finger on the washer button, the wipers will stay wiping till a minute after I did.
The result was always a hazed up windshield with streaks all over the place because the wipers have been wiping a dry windshield for a minute.
 

·
Registered
06 CTS Sport/Luxury package
Joined
·
9,803 Posts
Well in my case back then, after I sparay my windshield my wipers keep going for a minute. No matter how long or short I kept my finger on the washer button, the wipers will stay wiping till a minute after I did.
The result was always a hazed up windshield with streaks all over the place because the wipers have been wiping a dry windshield for a minute.
But it's controlled by the same electronics. Which is located in a dumb location with in the motor housing. Replacing it should resolve the problem.

KOT
 

·
Registered
07' CTS-V | 07' Lux 3.6 Volant-Borla-Vsways | 08' CTS 3.6 DI Performance
Joined
·
969 Posts
Yes that motor cover board has many modes of failures, it seems each case is different with the root cause being one.
 
1 - 8 of 8 Posts
Top