Cadillac Owners Forum banner

1 - 16 of 16 Posts

·
Registered
2012 Cadillac CTS 3.6 Premium AWD
Joined
·
222 Posts
Discussion Starter #1
My windshield wiper fluid pump sprays wiper fluid on my windshield/sunroof as well as any other surface in the spray zone.

This gets really annoying when the wiper fluid dries on my paint and causes streaking. Has anybody else had this issue? I am taking it in for an oil change tomorrow and wondering if it is worth mentioning.
 

·
Registered
2012 Black Diamond tricoat 3.0 awd cts
Joined
·
143 Posts
My windshield wiper fluid pump sprays wiper fluid on my windshield/sunroof as well as any other surface in the spray zone.

This gets really annoying when the wiper fluid dries on my paint and causes streaking. Has anybody else had this issue? I am taking it in for an oil change tomorrow and wondering if it is worth mentioning.
Clean the orifice with rubbing alcohol.
 

·
Registered
2011 CTS-4, Sedan,Tuscan Bronze
Joined
·
388 Posts
I don't know if you can do it to a Caddie but with my Saab I was able to adjust the nozzle. All it took was a small pin, stick it in the nozzle hole and move it whichever way you needed. In your case that would be down.
 

·
Registered
'14 CTS-V LongRoof; '16 ATS-V Sedan,' 04 Trailblazer 4x4; '10 CTS LongRoof gone but never forgotten
Joined
·
15,100 Posts
Maybe a sewing needle, it's longer and narrower sometimes.
 

·
Registered
2012 CTS4 (AWD)
Joined
·
118 Posts
When I was a kid we used to prank people by completely turning the nozzles 180° so that they'd be pointing towards the front of the car. Many lols...
 

·
Registered
08 CTS blk/blk
Joined
·
383 Posts
My spray has become pretty wimpy; barely hitting the middle, is this the pump going bad?
 

·
Registered
08 CTS blk/blk
Joined
·
383 Posts
Hahaha....but then I might have a new problem...over spraying on to my roof!!

Good stuff..thanks for the laugh
 

·
Registered
2013 Black Diamond CTS4 Premium Coupe (sold-09 CTS4 DI Black Raven/Ebony)
Joined
·
4,372 Posts
Joe, it could be the cold. If there is some freezing going on, it can block flow and result in what you are seeing. Mine will work till about 0 degrees, then it drops off a little. At -8 it stops pumping. In my case, it's the pump having trouble, the fluid is fine. Might be some moisture affecting the pump, I don't know. I just hope temps stay above 0 and I'm good.
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
70,405 Posts
............ of course, none of the spray (or solid fluid from the wipers) ever blows/flows anywhere else than on the windshield glass. :helpless:
 

·
Registered
'14 CTS-V LongRoof; '16 ATS-V Sedan,' 04 Trailblazer 4x4; '10 CTS LongRoof gone but never forgotten
Joined
·
15,100 Posts
One thing that ticks me off is when I am cruising along and some moron directly in front of me washes both his windshield AND mine. I get upset with this moronic move. It is everything I can do to get in front of them and return the favor a couple of times over! Off topic :Offtopic: but delighted to write it! :woohoo:
 

·
Registered
2014 CTS Coupe 3.6 RWD Perfomance Pkg, TriCoat White Diamond
Joined
·
1,723 Posts
One thing that ticks me off is when I am cruising along and some moron directly in front of me washes both his windshield AND mine. I get upset with this moronic move. It is everything I can do to get in front of them and return the favor a couple of times over! Off topic :Offtopic: but delighted to write it! :woohoo:
LTM, you just said what we all were thinking...
 
1 - 16 of 16 Posts
Top