Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
1971 CAdillac Eldorado
Joined
·
5 Posts
Discussion Starter #1
Hi,

My neighbour has bought a 1971 Cadillac Eldorado and I would like to help him repairing a few components so it can pass the safety check in order for him to put it safely on the road.

The Windshield Washer Pump doesn't seem to work and I was wondering if you can help in troubleshooting the parts related to it.

The wipers are working but when we press the button for the windshield washer, nothing comes out.

I have looked at all of the black tubings and none of them are blocked.

I was wondering if someone knew how I can test the electrical parts on the pump i.e. continuity, voltage, etc... as I have a multi-meter that I can use for troubleshooting.


I noticed that some of the metal connectors were a bit discolored i.e. corroded a bit, so my next step would be to sand these a bit to make sure a proper connection is made.

Any help on the troubleshooting would be appreciated. Thanks.
 

·
Registered
1997 Eldorado ETC
Joined
·
53 Posts
Michel10,
Have you checked the hot wire to the pump to make sure you're getting power? if you are getting power from the hot wire, check the switch to make sure it is properly completing the circuit. From my experience if both of those are in working order the pump usually needs replacing.

-Davis
 

·
Registered
1971 CAdillac Eldorado
Joined
·
5 Posts
Discussion Starter #4
Thanks for the info... Can you please provide the details in regards to "getting power from the hot wire" i.e. with my multi-meter.
Thank you...











|
 
1 - 4 of 4 Posts
Top