Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Cadillac Escalade Base
Joined
·
59 Posts
Discussion Starter #1
So pretty much i recently installed the uPAC-GMC2 audio controller so I can use my i-touch to play songs. Anyway Im pretty sure since the installation of the uPAC my radio whistles when I hit the gas and the faster I go the louder it whistles :banghead:. I can turn down the music and it will no longer whistle but once its turned up again it whistles.. Has anyone else had this problem because of the uPAC controller or is there something else that may cause this that I can fix. Any help is always appreciated. Thanks guys :D
 

·
Registered
04 Ext, 94 deville
Joined
·
198 Posts
Sounds to be a ground problem! Check your ground and try a different spot! Pretty sure that is your problem! Never installed one myself but a whistle is a sure sign of poor ground! Hope this helps!
 

·
Registered
Cadillac Escalade Base
Joined
·
59 Posts
Discussion Starter #5
What ground should I check because the uPAC-GMC2 audio controller didn't require or have a ground to hook up. It just pretty much took the spot of the (2) male wires that plug into the navi and had female adapters on the other side of the controller to reconnect the old existing wires that were already plugged in.
 

·
Registered
04 Ext, 94 deville
Joined
·
198 Posts
Try to relocate the unit also away from climate control unit and anything else which could cause interference! Tuck away back in dash as far as possible away from other electronics! Move around with truck running and nav unit out to see if it makes a difference! Hope this helps!
 
1 - 6 of 6 Posts
Top