Cadillac Owners Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
I was running a Northstar in my rock buggy up until last week when it tossed a rod through the valley right under the starter at just above idle.

I assume I damaged the motor earlier maybe from an overheat up to 260 for about 10 miuntes(fan relay failed)but the oil never went to cream and it wasn't using coolant so I thought I was ok.

Now I am gun shy about replacing it, and I am thinking about a supercharged 3800 series 2.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #6
I am pretty sure the abuse I give the motor had something to do with it, but I have seen 2 others in junkyards the same way still in the car.
 

·
Premium Member
2006 STS V8 AWD, '95 Ford Ranger
Joined
·
29,097 Posts
Northstar rods are about as exotic as stock rods get. They are powder forged with cracked caps. You must have been turning about a jillion RPM.
 

·
Registered
98 sls Northstar
Joined
·
14 Posts
Thanks for the info, 2dedge. I couldn't reply because I am not yet allowed PM's yet. I'll tell you about my setup if I can get through to you somehow, you could email me at dan (at) glenellenlabs (dot) com.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #10
Well after further research it destroyed the piston and the schrapnel came through the block not the rod.
 

·
Registered
'03 STS 122K, '01 STS 161K - 3/3/11
Joined
·
671 Posts
pics?

I've put the pic of your buggy up on my work computer and everyone loves it.
 

·
Registered
The Northstar Tuner
Joined
·
2,759 Posts
let me guess you have been using a Commander 950? Don't feel bad I hear about this type of thing with them and the Fan Thing also
 
1 - 13 of 13 Posts
Top