Cadillac Owners Forum banner

1 - 15 of 15 Posts

·
Registered
2005 Cadillac CTS-V
Joined
·
428 Posts
Discussion Starter #1
This happened to me on the weekend. I did the throttle relearn, and it worked. It hasnt happend since, but I was wondering why it did this. I was going WOT when this happened. Could it be a TPS sensor going bad?:confused:
 

·
Registered
2009 Z06 / 2013 F150 EcoBeast / 2008 Twin-Turbo Bimmer
Joined
·
4,860 Posts
One of the more common causes on modified cars is if the actual airflow exceeds the airflow predicted by the PCM.

Do you have headers or a supercharger?
 

·
Registered
2005 Cadillac CTS-V
Joined
·
428 Posts
Discussion Starter #5
Only mods are tune, K&n panel filter, and magnaflow catback.

I wonder if it has anything to do with my tune. Hmm. I tuned it myself btw, but it just started doing it, and I've had my tune in it for about 4 months.
 

·
Registered
Joined
·
1,685 Posts
May have been a leak in your intake. Since you only have the K&N panel filter and not an entire aftermarket CAI, its unlikely.
 

·
Registered
2009 Z06 / 2013 F150 EcoBeast / 2008 Twin-Turbo Bimmer
Joined
·
4,860 Posts
When the reduced power mode hits, are there any DTCs set such as P1514?

If so, with EFILive increase C6101 by 25% as a temporary fix. To make a "real" C6101, create a map that matches PIDs, log real-world data and see how it compares to the factory values. Use that data to update C6101 as necessary.

In HPT software, the same table can be found in Engine Diagnostics > General > TPS Sensor > Calculated Airflow vs. TPS vs. RPM - P1514 Error

For LSxEdit, you're on your own; I don't have that one to help you with.
 

·
Registered
2011 CTS-V Coupe
Joined
·
1,635 Posts
My maggied V did this today at the track. She's still there. The engine power reduced light comes on before i even start the car. I can also hear some wierd clicking going on in the fuse box when i turn the key to on, maybe a bad relay or something? Any ideas? I guess ill head out there with a trailer tomorrow. Im worried....
 

·
Registered
2005 Cadillac CTS-V
Joined
·
428 Posts
Discussion Starter #13
Stealth V, I changed the throttle error table like you said, and my car as been running flawlessly! Thank you!

Im just stoked on how it can be reading so much air intake being that I have just a cat back, K&N drop in filter, and a tune. Weird
 

·
Registered
2011 CTS-V Coupe
Joined
·
1,635 Posts
Bring a new throttlebody with and drive it home.
When i bought the maggie it showed up with a throttle body, so i just used that one. Not sure how old it was or anything, so hopefully its that easy of a fix. Thankfully i saved all my stock parts. I will certainly give that a try! Thanks a lot! :bouncy:
 

·
Registered
2011 CTS-V Coupe
Joined
·
1,635 Posts
Replaced the throttle body and it worked! I still think something is wrong, she just doesnt feel quite right, we'll see with time. One problem down though, thanks StealthV!
 
1 - 15 of 15 Posts
Top