Cadillac Owners Forum banner

21 - 32 of 32 Posts

·
Registered
96 Fleetwood, 94 Fleetwood, 07 CTS, & 94 Caprice Wgn
Joined
·
694 Posts
Discussion Starter #21
I am clueless, but I'll guess 1. either something to do with the cowl or 2. a piece of the front bumper?

But I really think it's just a piece of junk that has nothing to do with the car. BUT, don't throw it away just yet.

Tom
 

·
Registered
95 FWB 81SDV 96 FWB 94 Fleetwood
Joined
·
1,532 Posts
I think it goes at the base of the windshield. When you open the hood its all the way at the back over the windshield wiper mechanism to keep stuff out of getting in there.
 

·
Registered
'91 Brougham
Joined
·
73 Posts
View attachment 584130 can someone shed some light on what this is and where it goes please? Found in the trunk of a 91 brougham
It
I think it goes at the base of the windshield. When you open the hood its all the way at the back over the windshield wiper mechanism to keep stuff out of getting in there.
Thats exactly what I thought but it just doesn't fit any way i flip it. I suppose I'll have to look at some pictures of other broughams and see its positioning.
 

·
Registered
96 FWB
Joined
·
773 Posts
Don't discount it still being a cowl cover (my first dumb guess), mayhaps just found (by someone earlier) not to be for exactly your model. It all depends on how it got in the trunk of that car in the first place eh.
 

·
Registered
'91 Brougham
Joined
·
73 Posts
Thanks all for the replies. Basically rebought back my old 91 brougham I sold 5 years ago and always regretted letting go of. Tried to fill the hole with an 88 but just wasn't the same. By some miracle I found my exact car listed on Letgo a few weeks ago and bought it back a few days ago. Now I am in the process of cleaning and polishing it up, seeing whats changed on it etc. Some good and some bad.

The good: Headliners been restored, HIDs and LEDs i put in the headlights and interior courtesy lights all still working, rear tail lights been straightened out. Also finicky wipers and cruise control appear fixed as well.

The bad: about 5k miles tacked on, couple cracks in the dash that were never there, only one of the the light displays on the hood work although both rear cat eyes are working. Also neither cornering light is coming on so I'll have to take a look at those as well.

Found this in the glove compartment, guy said it was the relay that would auto lock and unlock the doors when shifting into Drive and Park, but it stopped working. Not a major issue but can someone please tell me exactly where it goes? I'll probably end up replacing it as it cant be too expensive. Not too many junkyards near me so I'd have to order a new one online.
 

Attachments

·
Registered
'91 Brougham
Joined
·
73 Posts
Today I added a can of R12 into the system and what a world of difference. Glad no one tried to convert it because a few cans of original R12 and it's running like it should. Also installed a Heritage of Ownership badge on the grill (someone removed old one for some reason??) and noticed quite a bit of rust on the undercarriage. I plan on getting some estimates on price for having the rust cleaned and the underside sprayed with rubber undercoating. I'd do it myself but I don't have a lift and not really an expert on what can be sprayed and what can't.
 

·
Registered
90 Brougham 5.7, 05 Deville DTS
Joined
·
1,176 Posts
Thanks all for the replies. Basically rebought back my old 91 brougham I sold 5 years ago and always regretted letting go of. Tried to fill the hole with an 88 but just wasn't the same. By some miracle I found my exact car listed on Letgo a few weeks ago and bought it back a few days ago. Now I am in the process of cleaning and polishing it up, seeing whats changed on it etc. Some good and some bad.

The good: Headliners been restored, HIDs and LEDs i put in the headlights and interior courtesy lights all still working, rear tail lights been straightened out. Also finicky wipers and cruise control appear fixed as well.

The bad: about 5k miles tacked on, couple cracks in the dash that were never there, only one of the the light displays on the hood work although both rear cat eyes are working. Also neither cornering light is coming on so I'll have to take a look at those as well.

Found this in the glove compartment, guy said it was the relay that would auto lock and unlock the doors when shifting into Drive and Park, but it stopped working. Not a major issue but can someone please tell me exactly where it goes? I'll probably end up replacing it as it cant be too expensive. Not too many junkyards near me so I'd have to order a new one online.
That green box pictured is the chime module (I do not know the technical name of the part). It’s responsible for the “ding ding ding” sound effect when the key is in the ignition and driver door is open, reminder if the headlights are on while car is off, seatbelt reminder when first starting the vehicle.

It plugs in towards the middle bottom part of the dashboard, below and behind the radio.
 

·
Registered
1979 Sedan Deville
Joined
·
451 Posts
I've been re-doing the suspension on my 1979 Sedan Deville. I had Vogtland lowering springs and Bilstein 1104/0929 shocks on it, and I got tired of the low, stiff ride, so I'm going back to stock height. I ordered the Moog springs that rock-auto lists as the heavy duty spring for the 1979 Fleetwood Brougham, and AC Delco shocks recommended on the Impala SS forums for a nice ride. Also put in all new bushings on the control arms.

I did that a few weeks ago, but I accidentally stretched the brake hose, so this weekend I replaced that. Pain in the butt, and I hope it doesn't leak. I got it as tight as I thought was safe where it connects to the frame, but it kind looks like the hard line can still wiggle inside the nut... I'll refill and bleed this weekend and check it.
 

·
Registered
'91 Brougham
Joined
·
73 Posts
That green box pictured is the chime module (I do not know the technical name of the part). It’s responsible for the “ding ding ding” sound effect when the key is in the ignition and driver door is open, reminder if the headlights are on while car is off, seatbelt reminder when first starting the vehicle.

It plugs in towards the middle bottom part of the dashboard, below and behind the radio.
Thanks that makes sense because I noticed the chime no longer working. I'll try to find a replacement online.
 

·
Registered
Cadillac
Joined
·
834 Posts
I've been re-doing the suspension on my 1979 Sedan Deville. I had Vogtland lowering springs and Bilstein 1104/0929 shocks on it, and I got tired of the low, stiff ride, so I'm going back to stock height. I ordered the Moog springs that rock-auto lists as the heavy duty spring for the 1979 Fleetwood Brougham, and AC Delco shocks recommended on the Impala SS forums for a nice ride. Also put in all new bushings on the control arms.

I did that a few weeks ago, but I accidentally stretched the brake hose, so this weekend I replaced that. Pain in the butt, and I hope it doesn't leak. I got it as tight as I thought was safe where it connects to the frame, but it kind looks like the hard line can still wiggle inside the nut... I'll refill and bleed this weekend and check it.
Excellent job on the suspension! How do you work on the front springs? I played hell with the springs on my '77 last year. Removal is the easy part.. installing, ha! Major tough.

I used spring compressors that were super low-profile and narrow and clamped/compressed the springs down from the inside. Holyyeeee difficult. Curious how you do it?
 

·
Registered
'91 Brougham
Joined
·
73 Posts
It plugs in towards the middle bottom part of the dashboard, below and behind the radio.
Today I replaced the GA-Transe Fuse 20A that re-illuminated my Instrument panel Indicator lamps, and should provide power to the Chime module. I'm willing to bet the module was never bad, but the fuse went so the guy before me pulled it out assuming it went.

Can you tell me exactly how put this part back in? I have the service manual but it is rather vague. I removed the under dash panels on drivers and passengers side looking for where it plugs in but I can't find exactly where it goes. Do I have to remove the radio?
 
21 - 32 of 32 Posts
Top