Cadillac Owners Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
149 Posts
Discussion Starter #1
Ok so usually these codes come up when i run them in my car for my service engine light.

P1035
P0141
P0147
P0155
AND
P1139

They usually read all of them but i check again and now the P1139 is just showing up. This means

Ho2S "o2 bank1 sensor1 insuffiecient switching.

Why did it used to read all of them and now is just reading this code? what does insufficient switching mean? help me out guys?!
 

·
Registered
2005 CTS-V, 1994 Infiniti Q45
Joined
·
7,658 Posts
Well all those other codes were probably history codes, and you cleared the codes and they went away.... Usually the history codes have to do with stuff like "engine near miss detected" or something along those lines.....

Insufficient switchings means the o2 sensor needs to be replaced..... The o2 sensor during cruise or mild acceleration directly controls the injector open time (when at operating temp).... Anyway, the computer controls the injector open time when the o2 sensors arent doing a good job.....

I dare say you will see some performance and gas mileage increase...... Also, i would replace ALL 02 sensors....
 

·
Registered
Joined
·
149 Posts
Discussion Starter #3
WES!!! I JUST REPLACED ALL OF THEM LESS THAN 2 WEEKS AGO!!!?? what is the deal here? :banghead:
 

·
Registered
2005 CTS-V, 1994 Infiniti Q45
Joined
·
7,658 Posts
Oh..... Sorry, I didnt remember that you did that!!!! I have a lot of things to keep track of.....

Anyway, I guess I would check the harness connections..... Without a FSM, im not sure what to say..... I bet its electrical.....
 

·
Registered
1968 Cadillac Sedan deVille, 1994 Chevrolet G20
Joined
·
2,795 Posts
Did you by any chance get the "universal" O2 sensors? If so, how did you splice them in? A poor connection could cause that code and inaccurate info to be fed into the computer.
 

·
Registered
Joined
·
149 Posts
Discussion Starter #6
DaveSmed said:
Did you by any chance get the "universal" O2 sensors? If so, how did you splice them in? A poor connection could cause that code and inaccurate info to be fed into the computer.
I didnt put any universal o2 in. Didnt have to splice anything they all fit in there 2 before the cat and 2 after if im not mistaken. I just dont know what else to do! :crying2:
 

·
Registered
1968 Cadillac Sedan deVille, 1994 Chevrolet G20
Joined
·
2,795 Posts
Are the manifold sensors the same? If so, I would swap them and see if the code follows. If it does, take the sensor back. If it doesn't, it is almost definitely a wiring fault. Check the connector and the wires for heat damage.
 

·
Registered
Joined
·
149 Posts
Discussion Starter #8
DaveSmed said:
Are the manifold sensors the same? If so, I would swap them and see if the code follows. If it does, take the sensor back. If it doesn't, it is almost definitely a wiring fault. Check the connector and the wires for heat damage.
All my sensors are bosch. How do i swap the manifolds?
 

·
Registered
1968 Cadillac Sedan deVille, 1994 Chevrolet G20
Joined
·
2,795 Posts
Not the manifolds, the O2 sensors. Before you do, check and see if they have the same connector.
 

·
Cadillac Owners Connoisseur
Joined
·
1,164 Posts
Re: weird O2 sensors problem

DaveSmed said:
Not the manifolds, the O2 sensors. Before you do, check and see if they have the same connector.
The "front" O2 sensors (accessible from engine compartment) are unheated and have a different connector than the heated "rear" sensors (one before and one after the cat). They are not interchangeable.

It sounds like either bad wiring somewhere in the circuit or a bad O2 sensor. Yes, I realize they are new and it's frustrating, but you've got limited options at this point. Try switching the sensors before and after the catalytic and see if the code changes. If it does, you'll know it's a bad sensor. If not, it's probably bad wiring between the harness and computer but will require further diagnosis.
 

·
Registered
Joined
·
149 Posts
Discussion Starter #11
Well i am taking it to the shop tomorrow and see what happens. I heard its probably a dirty fuel injector? oh well wish me luck and wish my pockets the same! i'll let you guys know
 
1 - 11 of 11 Posts
Top