Cadillac Owners Forum banner

1 - 19 of 19 Posts

·
Registered
2K ELDO WHITE DIAM , 2K TURBO BUG ,69 VETTE ZZ4 2014 CTS
Joined
·
534 Posts
Discussion Starter #1
Well, I just replaced the a/c relay , erased all the codes and expected all to be well , But no ! Now the a/only blows cold on the passenger side not the drivers side ? Could there a blend door stuck or vacuum leak. I don't really know where to start on this one . Thanks for any help or ideas on this one . Hope its not to ugly
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,250 Posts
Well, I just replaced the a/c relay , erased all the codes and expected all to be well , But no ! Now the a/only blows cold on the passenger side not the drivers side ? Could there a blend door stuck or vacuum leak. I don't really know where to start on this one . Thanks for any help or ideas on this one . Hope its not to ugly
===========================
I don't really know where to start on this one .
like always - start by checking for codes -

if no AC related codes -
check the AC pressures -
post BOTH the high side and low side pressures -
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,781 Posts
Is the drivers side warm (ambient) or hot?
If warm, then you probably just need a refrigerant top off.
If hot, then it is more likely an air mix door actuator.
 

·
Registered
2K ELDO WHITE DIAM , 2K TURBO BUG ,69 VETTE ZZ4 2014 CTS
Joined
·
534 Posts
Discussion Starter #4
Tx ill check on this tommrow. Air is not "hot" more abient. No codes because I recently cleared them when I replaced the relay.
 

·
Registered
2K ELDO WHITE DIAM , 2K TURBO BUG ,69 VETTE ZZ4 2014 CTS
Joined
·
534 Posts
Discussion Starter #5
Finally got back to this Sunday AM. And I have a few more facts, Outside temp about 70 degrees . Passenger side vents are reading 50/52 degrees. and drivers side vents reading 80/82 degrees. No codes are showing up and I have a high side pressure of 175 /200. I cant do a low side pressure because my brother drove over the low side , when he used it last , TX Bro. Any additional ideas would be appreciated TX.
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,250 Posts
Finally got back to this Sunday AM. And I have a few more facts, Outside temp about 70 degrees . Passenger side vents are reading 50/52 degrees. and drivers side vents reading 80/82 degrees. No codes are showing up and I have a high side pressure of 175 /200. I cant do a low side pressure because my brother drove over the low side , when he used it last , TX Bro. Any additional ideas would be appreciated TX.
======================
high side pressure seems about right for 70's ambient -

duct temp - when set to 60* - medium speed -
should be 42 or lower -

your driver side temp is above ambient -
passenger side is below ambient -

the Eldo still uses a mix of vacuum and electrical controls -
can't remember which controls what - between temp and mode -

I suspect a vacuum leak -

but am surprised there are no codes -

----------------

could be a mix door sticking -

try exercising the temp up to 90*
and down to 60* several times -
 

·
Registered
2K ELDO WHITE DIAM , 2K TURBO BUG ,69 VETTE ZZ4 2014 CTS
Joined
·
534 Posts
Discussion Starter #7
Thanks Basscatt1 I will try the" exercise" method tonight . Any access to those doors on the drivers side ?
 

·
Registered
2K ELDO WHITE DIAM , 2K TURBO BUG ,69 VETTE ZZ4 2014 CTS
Joined
·
534 Posts
Discussion Starter #9
Thanks , for the diagrams Ranger , I was looking for something like this in the FSM but couldn't find it .After" exercising "the system like Basscatt recommended , I noticed that in the air conditioning mode the drivers vents are not blowing as hard as the passengers , in the heat mode they appear to be equal . Momentarily I thought that It was working but then it went back to not working . Is there anyway to physical check and move the blend doors by hand to check for movement . Also is it possible for a screw or something to fall down a vent get in there and mess things up . I've had the dash pad off so who knows . TX again for all the help.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,781 Posts
After" exercising "the system like Basscatt recommended , I noticed that in the air conditioning mode the drivers vents are not blowing as hard as the passengers , in the heat mode they appear to be equal . Momentarily I thought that It was working but then it went back to not working .
Make sure there are no vacuum leaks.

Is there anyway to physical check and move the blend doors by hand to check for movement .
Probably. look under the IP on the drivers side. Not sure how accessible things are down there.

Also is it possible for a screw or something to fall down a vent get in there and mess things up .
Not likely.
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,250 Posts
Thanks , for the diagrams Ranger , I was looking for something like this in the FSM but couldn't find it .After" exercising "the system like Basscatt recommended , I noticed that in the air conditioning mode the drivers vents are not blowing as hard as the passengers , in the heat mode they appear to be equal . Momentarily I thought that It was working but then it went back to not working . Is there anyway to physical check and move the blend doors by hand to check for movement . Also is it possible for a screw or something to fall down a vent get in there and mess things up . I've had the dash pad off so who knows . TX again for all the help.
----------------------------
I noticed that in the air conditioning mode
the drivers vents are not blowing as hard as the passengers ,
in the heat mode they appear to be equal

don't confuse the TERMS within the climate control system -

MODE DOORS controls WHERE the air blows from -
regardless of temperature -

MIX DOORS control TEMPERATURE -
regardless of the MODE -

----------------------

the Eldo never got the upgrades/improvements to the CC system-
that the Deville and Seville got -
no manual MODE control - and still vacuum operated -

it is quite possible you have vacuum leaks messing stuff up -
 

·
Registered
2K ELDO WHITE DIAM , 2K TURBO BUG ,69 VETTE ZZ4 2014 CTS
Joined
·
534 Posts
Discussion Starter #12
More information! Tx. I'll be looking at this over the weekend and report back tx again.
 

·
Registered
2K ELDO WHITE DIAM , 2K TURBO BUG ,69 VETTE ZZ4 2014 CTS
Joined
·
534 Posts
Discussion Starter #13
Finally got back to this over the weekend . I checked the incoming vacuum and found it to be around 16 Hg . I checked the colored vacuum hoses with a vacuum gauge and found them all to hold vacuum' I still need to see if a actuator is stuck . So where do I go next ? Vacuum solenoid or the programmer. I still have no codes showing. High side pressure is still around 200. Is it possible to have correct high pressure and be short on R134a ?
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,250 Posts
Finally got back to this over the weekend . I checked the incoming vacuum and found it to be around 16 Hg . I checked the colored vacuum hoses with a vacuum gauge and found them all to hold vacuum' I still need to see if a actuator is stuck . So where do I go next ? Vacuum solenoid or the programmer. I still have no codes showing. High side pressure is still around 200. Is it possible to have correct high pressure and be short on R134a ?
=====================
High side pressure is still around 200.
Is it possible to have correct high pressure and be short on R134a ?

high and low pressures work together -
and are BOTH relative to ambient temp -

high pressure alone is almost useless -
likewise - low pressure alone isn't much help -
 

·
Registered
2K ELDO WHITE DIAM , 2K TURBO BUG ,69 VETTE ZZ4 2014 CTS
Joined
·
534 Posts
Discussion Starter #15
Looks like I will need to buy a new set of gauges! Ill keep working on this as time permits. Tx.
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,250 Posts
Looks like I will need to buy a new set of gauges! Ill keep working on this as time permits. Tx.
============================


Mountain 8205 - $56 - with free shipping -
http://www.amazon.com/Mountain-8205-R-134a-Manifold-Couplers/dp/B000JFHNG0
very high quality set -
nice 6' long hoses -
quick connect couplers for both high and low sides -

found a set on ebay for $46 - with shipping -
http://www.ebay.com/itm/Mountain-MTN8205-R134A-Brass-Manifold-w-72-Hoses-High-Low-Quick-Couplers-/301391552349?pt=LH_DefaultDomain_0&hash=item462c561f5d
 

·
Registered
2K ELDO WHITE DIAM , 2K TURBO BUG ,69 VETTE ZZ4 2014 CTS
Joined
·
534 Posts
Discussion Starter #17
Just got back to this , I noticed when the fan is on with Air conditioner off it still blows warm on driver and outside air on passenger. so I'm pretty much convinced it is a stuck door or vacuum motor problem . No codes are present . I cant figure out how the short side panels are removed from front of the shift console. the ones by the gas pedal and the passengers left foot . They seem to move around but I can't get them to come off . I don't want to break anything . Didn't see anything on the FSM on this . I figure if I can see what's going on down there I might be able to figure this out .TX Eldo GUY
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,781 Posts
Disclaimer:
The Eldo is different than my DTS console, but mine is pried loose from the rear, then work your way forward. The front has a 90 degree angle tab that is slid in to hold it. Pry the front and you break that tab.
Mine was broken when I got it and I had to JB Weld it. Once all the retainers are popped, you slide the panel rearward.

Check this link on Ebay. It has a picture of the backside. Look closely at the front and you can see the tab I'm talking about.
http://www.ebay.com/itm/Cadillac-SEVILLE-98-99-00-01-02-03-04-Center-Console-LEFT-SIDE-TRIM-PANEL-Cover-/281713405917?hash=item41976d6fdd&vxp=mtr
 

·
Registered
2K ELDO WHITE DIAM , 2K TURBO BUG ,69 VETTE ZZ4 2014 CTS
Joined
·
534 Posts
Discussion Starter #19
TX. again ranger ill try and explore this option tonight . Hope fully with the help of the forum and me poking around I'll figure this out . I will update when I find out something new .
 
1 - 19 of 19 Posts
Top