Cadillac Owners Forum banner
1 - 3 of 3 Posts

·
Registered
1990 Cadillac Seville
Joined
·
1 Posts
Discussion Starter · #1 ·
I just replaced the alternator and battery in my 90 Seville, but since I've started it up again the water pump (I believe), has started whistling a little bit. Should I be worried? How urgently should I think about replacing the water pump? So far it looks like it's not leaking, and the car is driving fine, the water pump just whistles.
 

·
Registered
2017 ATS-V Coupe / Blood Red...bleeding carbon fiber :)~
Joined
·
12 Posts
I just replaced the alternator and battery in my 90 Seville, but since I've started it up again the water pump (I believe), has started whistling a little bit. Should I be worried? How urgently should I think about replacing the water pump? So far it looks like it's not leaking, and the car is driving fine, the water pump just whistles.
I had the same issue on my 2017 ATSv. it would make a gasping noise. The water pump needed to be replaced. i havent gotten it back from cadillac yet, i dont think it was not functioning or was detramental....more annoying than anything else. I can update when i get her back.
 

·
1999 STS
Joined
·
41 Posts
I just replaced the alternator and battery in my 90 Seville, but since I've started it up again the water pump (I believe), has started whistling a little bit. Should I be worried? How urgently should I think about replacing the water pump? So far it looks like it's not leaking, and the car is driving fine, the water pump just whistles.
My 93 deville with the 4.9L did this before 2 pumps died thankfully I had about 2 months each time of excessive driving before catastrophic failure and motor started running hotter than usual before the pulley let go completely and took out the belt with it , the noise will get worse as well and turn into a louder whistling grinding noise, watch for it getting louder would be the best advice to know for sure if you have the same problem also watch the pulley while its moving and see if it looks like its wobbling a little. I never got a leak out the weep hole either both those times, the bearings on the pumps appeared to make the noise and can get ruined from coolant leaks wear and tear, my case hard driving and I bought a cheap pump to fix it the first time
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top