Cadillac Owners Forum banner

1 - 3 of 3 Posts

·
Registered
2001 Deville Base
Joined
·
2 Posts
Discussion Starter #1
My car is an 01 deville base. It has been running perfectly, except I had a noisy pulley making a constant screeching sound. I had an appointment to get it looked at Friday. I stopped in at my mothers house left the car idling outside for 10 mins, and when I came out the screeching had stopped. But when I got in the car the temp gauge was up, and the fans were on. It continued to get hotter so I shut it down. The belt is still there, I'm not missing any coolant, and it never overflowed and there is no smell of coolant. Is it possible for the waterpump to fail internally?
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
68,507 Posts
Re: Water pump failure?

Your water pump drive belt tensioner pulley has probably failed, seizing the pulley bearing and destroying the left (front) intake cam water pump drive pulley. You'll need to remove the steel shroud and take a look.

Many, many threads and posts on this with pictures here, in Seville, and in Northstar Performance. "How-to" fix threads in Cadillac Tech Tips.

Google "cadillac forums northstar water pump drive system" or "cadillac forums northstar water pump drive belt tensioner pulley".

If the pulley(s) are damaged, the tensioner pulley/bearing can be replaced separately from the tensioner. The cam driver pulley MUST be carefully removed and installed with the proper tools or you risk severe and expensive damage to the cam and valve system. It's all DIY, but you MUST DIY correctly.

Not discounting the water pump assembly itself, but they seldom seize....... BUT there are special tools and procedures to changing that assembly also.

Pictures of all the parts in my albums. Click my username, open the profile. left column, 2 albums, 6 pages of Northstar stuff for your engine.
 
1 - 3 of 3 Posts
Top