Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter #1
When I have the car in drive, the lights on, and the economy blower on, the voltage drops to 12.8 which seems realy low to me. Is it a bad alternator? I have a brand new battery.

Otherwise with the car just running and in park with nothing on, it's at about 14.0.
 

·
Registered
Cadillac
Joined
·
49 Posts
Take it to Autozone and have it checked out for free. You should show the same voltage at almost all rpms and it should be between 13.8 and about 15 volts. It shouldn't change much. 12.8 is low, but what concerns me is that it goes up to 14 where it should be. Again. I would take it to the car parts store where they have a charging system tester that takes just a few minutes to test just about everything in the charging system and it's free.

Dan
 

·
Registered
2008 SRX
Joined
·
403 Posts
12.8 is still higher than a fully charged battery of 12.6V so it is charging. And, the DIC always reads a bit lower than actual. Measure with a voltmeter from the Alt output terminal to the Alt neg battery cable for comparison. If the car is working fine, don't read too much into it (if it ain't broke,.....)
 

·
Registered
Cadillac
Joined
·
49 Posts
Your alt should put out a minimum of 13.8. I'm not sure why it is dropping to 12.8, but that is not enough. Could just be the regulator, which can be replaced if you know how to take apart an alt., but the going back to 14v confuses me, it should remain pretty constant.

Dan
 

·
Registered
Joined
·
40 Posts
when i put my a/c on my volts drop to 12.8 then it will say service transmission, and i would have to shut off the car and turn it back on, i have a new alternator, and new battery and still same thing
 
1 - 6 of 6 Posts
Top