Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
i have a 2015 escalade with 100,500 miles i have the 6 speed transmission. ive been getting a weird idling problem its not noticeable on the rpm needle.. its more like a shaking.. i have not noticed a problem while driving.. has anyone had the same problem... i have had replaced all fuel injectors, spark plugs, spark plug wires, maybe thinking one of two fuel pumps..
 

·
Registered
2015i ESV
Joined
·
44 Posts
Hello, we have the same 2015i ESV with the 6 speed. Had a similar issue, felt like rough idling while stopped a few years ago after we first got it. That was around 50K miles. To me it seemed like it was stuck in V4 mode while idling. As soon as it popped into V8 mode it smoothed out. I didn’t do anything about it, others on this forum said it was just the way this engine was. It went away after awhile and we are at 91K miles now and it never seems to do it anymore. We pull a 4000 lb ski boat and a 7000 lb Airstream travel trailer. When it’s in tow mode, there’s never any rough idling.

Maybe try an AFM override module to keep it in V8 mode all the time, see if it goes away.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
My brother noticed a tick noise also. He said maybe the lifter stuck form the 4 to 8 cylinder mode. I wonder if that’s the problem. But I’ll try overriding it I have hp tuners with me
 

·
Registered
2015i ESV
Joined
·
44 Posts
Seems like a good place to start, did you say it smooths out as soon as it goes back into V8 mode?
 
1 - 4 of 4 Posts
Top