Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
2010 Wagon AWD
Joined
·
13 Posts
Discussion Starter #1
Hi everyone, this is for my 2001 Deville:

So over the past couple of weeks I have begun to have an issue where at highway speeds, my RPM's seem to jump around a little. For example, when cruise is on at 70 the RPM's will stay around 2000, then begin to fluctuate ~100-150 in each direction. I am in Michigan so I am not sure if the cold weather would cause this or not. Here is a video I put together on a few of these instances I have been able to capture. A couple of things before the video: this is on flat surfaces of road with the cruise on. No hills (up or down) are attempted. Also, the check engine light is on for the Cat. which I have since replaced and the light has not come back:

https://www.youtube.com/watch?v=SFT98kduBwQ

The problem goes away as soon as I start to accelerate, and there is no struggle in acceleration. Infact, I recently had the Cat replaced and have more power than before. I can also not hear the engine going up/down when this is happening, but I can slightly feel it. Almost like it is chugging slightly. Even though my check engine light is not on, I ran the codes and only have P0463 for the fuel level sensor (fuel gauge does not work).

Not sure what would be causing this, any info would be greatly appreciated.
 

·
Registered
2000 Deville DHS
Joined
·
759 Posts
Looks like no big deal to me.. That electronic readout isn’t going to be perfect to begin with, and since you’re using the cruise control I would expect those minor fluctuations to be normal considering the car is working to maintain that speed which means it’s going to be doing its fare share of accelerating and letting off in order to do so.

I used to own an 88’ Eldorado with digital readout for the RPMs and it never stayed completely steady, nor did I expect it to.
 

·
Registered
2010 Wagon AWD
Joined
·
13 Posts
Discussion Starter #3
Update: The variance was more sever this morning and could feel the engine struggling to keep up at certain points. Again, fine after accelerating a little.
 

·
Registered
2010 Wagon AWD
Joined
·
13 Posts
Discussion Starter #5
Now this has started happening without cruise control. Holding the petal at speed (70 mph for example) and will start to flutter.
 
1 - 5 of 5 Posts
Top