Cadillac Owners Forum banner

1 - 13 of 13 Posts

·
Registered
'14 CTS-V LongRoof; '16 ATS-V Sedan,' 04 Trailblazer 4x4; '10 CTS LongRoof gone but never forgotten
Joined
·
14,823 Posts
Discussion Starter #1
I have a V1 radar detector in my CTS. I bought it probably 10 or more years ago. It is hooked up to the ignition switch so it is on almost every second I drive. That being said, while driving anywhere or anytime, city or highway or in the middle of bufu with no one around, the "laser" alarm goes off and screams in my ear. The arrow shows it from behind. It is random, but too often. It is not a disconnect/reconnect because the power is good and the detector does not go through its entire startup bootup. There are no comments on the V1 website. Anyone with any ideas before I shit can this annoying POS?

By the way, it does this exact thing in my CTS-V as well. I have written V1 (today) but no response yet.
 

·
Registered
2010 Cadillac Premium AWD CTS
Joined
·
710 Posts
Hi, please post what they say. I am thinking of buying one myself. I don't want to buy one and find out it doesn't work as it should.
 

·
Registered
'14 CTS-V LongRoof; '16 ATS-V Sedan,' 04 Trailblazer 4x4; '10 CTS LongRoof gone but never forgotten
Joined
·
14,823 Posts
Discussion Starter #3
One thing to understand, this is definitely an older unit. It has been flawless up to now, and it has paid for itself many times over. It is a great radar detector!

I did not have my serial number which they need. I will get that tonight and send it to V1.

To be continued, and I will post back...
 

·
Super Moderator
'05 CTS-V
Joined
·
8,246 Posts
The last time mine was malfunctioning, I sent it back to them with a note explaining what the problem was, and they fixed it for free (plus shipping). At the time their website said you were supposed to send them like $50 or $60, but I didn't see that until after I had mailed it off; they didn't try to bill me for that amount, they just fixed it and sent it back. (Actually, as I recall they completely replaced the unit, because I had one of the older, thicker models and ended up with the current, thin style.) I have no idea if you would have the same result today - this was about 12 years ago.

Even if your laser detector wasn't going off all the time, apparently older models will alert on K-band almost all the time due to the various blind spot warning and lane departure warning systems that lots of cars have nowadays. There is a software upgrade for that, so I need to send mine in. I don't use it much since I'm in VA, so it hasn't been high on my priority list.

Hi, please post what they say. I am thinking of buying one myself. I don't want to buy one and find out it doesn't work as it should.
:confused: Hopefully your buying decision is not going to be solely based on a single reported malfunction.
 

·
Registered
'14 CTS-V LongRoof; '16 ATS-V Sedan,' 04 Trailblazer 4x4; '10 CTS LongRoof gone but never forgotten
Joined
·
14,823 Posts
Discussion Starter #5
Hopefully your buying decision is not going to be solely based on a single reported malfunction.
...and mine is easily over 10 years old, probably more like 15. I can't complain about any electronic device lasting that long, especially sitting inside my car in this hot Florida climate day after day. If I have to buy a new one I will gladly pay the price. This unit is one of the absolute best, and it has lasted a long time (and saved my butt many times over, enough to pay for this new one if need be).
 

·
Registered
2013 AWD Performance Coupe, 2011 Harley ElectraGlide Limited
Joined
·
122 Posts
I've had a V1 in my cars for years and what sets off the laser warning is a lot of GM SUV brake lights. Don't know what they are emitting, but if I pull up behind one, it often sets it off till they get off the brakes. Same thing can happen when one of those vehicles is going the opposite direction and brakes.

Not sure if other V1 owners get this like I do or not.
 

·
Registered
2010 Cadillac Premium AWD CTS
Joined
·
710 Posts
:confused: Hopefully your buying decision is not going to be solely based on a single reported malfunction.
No, but if there is a problem with using it in our cars, I would like to know. That way I can go from there and see my options.
 

·
Registered
'14 CTS-V LongRoof; '16 ATS-V Sedan,' 04 Trailblazer 4x4; '10 CTS LongRoof gone but never forgotten
Joined
·
14,823 Posts
Discussion Starter #9
I'm just waiting for their response. My software is current with what they are selling today, so that is not the culprit. (V1 offer software updates).
 

·
Registered
'14 CTS-V LongRoof; '16 ATS-V Sedan,' 04 Trailblazer 4x4; '10 CTS LongRoof gone but never forgotten
Joined
·
14,823 Posts
Discussion Starter #11

·
Registered
2013 Black Diamond CTS4 Premium Coupe (sold-09 CTS4 DI Black Raven/Ebony)
Joined
·
4,359 Posts
I rarely get the laser alarm with mine. But I'm definitely NOT on the current software release
 

·
Registered
2010 CTS Performance
Joined
·
14 Posts
Old thread, but your answer for most laser falses is ... Infiniti, Mazda, and the worst offender by far, Volvo. They have laser rangefinders in the windshield, and will set off the V1. Nothing you can do...
 
1 - 13 of 13 Posts
Top