Cadillac Owners Forum banner

1 - 20 of 34 Posts

·
Registered
Black the Darkside
Joined
·
22,415 Posts
Discussion Starter #1
About a week ago I left my CTS parked outside. The next morning the car would not start. Everything was dead..not a single sound or light. I called Cadillac Assistance and they came out and gave it the defibulator jolt and she fired right up. Tuesday of this week it happened again when the car was in the garage. Nothing..no sounds. I called Cadillac Assistance again. We kinda agreed that something was shorting out and rapidly draining the battery so they hauled it away. I hope the neighbors didn't see that!

It's been in the shop two days having all kinds of diagnostics tests run. But no luck yet. Meanwhile they hooked me up with a big Cadillac SLS Sled to drive. The prequill to the STS I think. What a boat!

I hope they don't try to give it back to me saying they found nothing wrong. My first serious problem with my Caddy.
 

·
Registered
Black the Darkside
Joined
·
22,415 Posts
Discussion Starter #6
My son, Luke Skywalker is closing in. I feel it in the force.:eek:

Geez OldRoadDawg you give your CTS-v the whole winter in the garage.
Sure..spoil the baby!!:rolleyes:
 

·
Registered
Joined
·
413 Posts
I just turned mine in today for a small valve cover oil leak, and they gave me an 05' CTS :) I asked them how much it would be to get the new Sports Package grille for my car, they said $440 painted and installed. Does that sound like a good price?
 

·
Registered
Joined
·
2,306 Posts
Sorry to hear that Robert. Keep us posted. I know I don't have to tell you not to take any BS from the dealership.
 

·
Registered
CTS
Joined
·
531 Posts
I never posted this but, mine had a dead battery bout a month ago. No biggie just a battery they all go bad some time. They found it was so bad it was leaking! They only found that out after removal as it was leaking from the back side.

Oh and you might want to change the title, I thought your car got crunched.:eek:
 

·
Registered
2013 3.6 Performance Luxury
Joined
·
1,034 Posts
ghostrider said:
AC Delco batteries are notorious for defective positive battery mounts.
Sure about that (have proof)? I've owned many and never had problems.
 

·
Registered
Black the Darkside
Joined
·
22,415 Posts
Discussion Starter #12
ghostrider said:
AC Delco batteries are notorious for defective positive battery mounts.
This is my second AC Delco. If it fails it will be my third:ill: I'm anxious for the morning to see if anything has been discovered. I have an idea but I need for them to suggest it?:annoyed:
 

·
Registered
2007 CTS-V, 2001 Honda Shadow Sabre
Joined
·
1,640 Posts
Cadiman1983 said:
I just turned mine in today for a small valve cover oil leak, and they gave me an 05' CTS :) I asked them how much it would be to get the new Sports Package grille for my car, they said $440 painted and installed. Does that sound like a good price?
Sorry for the hijack Bob but...

Cadiman - Is that for a new grille or a take-off? My local dealer got a new CTS in with the sport appearance package about a month ago. They had installed an E&G for the customer so I asked if I could buy the grille that came with the car. The guy told me they list for $450 and it would be another $100 for paint (its currently white diamond). He offered to give me a "deal" and knock $100 off (so basically full price but free paint). Went by today and the car still hasnt been delivered so he still cant sell me the grille, and doesnt sound like he'll budge on the price, even after I told him my second choice was to buy a V grill off e-bay for about $200. I really like the look of the sport appearance grille but personally, I cant justify the price at this point. I wonder how long until they show up on e-bay...

...anyways, back on topic...

Bob - sucks to hear about your problem, I hope your dealer figures it out quick before it comes time to install those sexy new cats you have on order. Otherwise they may somehow try to blame the problem on the fact that you planned to modify your car...:alchi:
 

·
Registered
Joined
·
50 Posts
Sorry no written proof, just experience and word of mouth. Do a search on AC Delco batteries and see other's experiences. The problem lies with the side mounted batteries only, the positve terminal corrodes and falls out.
I am not saying the batteries are horrible, I got three years out of the one in my Silverado (which is a miracle in Arizona for a lead cell battery). The battery failed, because of the defect.
Try talking to the technicians at a dealership, they could probably give you some insight as they do not sugar coat everything like the service advisors.
 

·
Registered
Black the Darkside
Joined
·
22,415 Posts
Discussion Starter #16
ghostrider said:
Sorry no written proof, just experience and word of mouth. Do a search on AC Delco batteries and see other's experiences. The problem lies with the side mounted batteries only, the positve terminal corrodes and falls out.
I am not saying the batteries are horrible, I got three years out of the one in my Silverado (which is a miracle in Arizona for a lead cell battery). The battery failed, because of the defect.
Try talking to the technicians at a dealership, they could probably give you some insight as they do not sugar coat everything like the service advisors.
The '03 & '04 had a lot of AC Delco failures. When mine first failed the dealership didn't even look at it. They brought a new one to my house and installed it. I've seen numerous other CTS owners with this problem. But so far the dealership doesn't think my problem is with the batteries and lies elsewhere. Maybe I'll learn more today.
 

·
Registered
Joined
·
413 Posts
Robert, same thing happened to my car about a month after I first bought it, went out too it and the whole car was dead. I pulled the battery and went too a few different shops, but nobody could match it for a better battery. So I just had to have the dealership replace it. Haven't had any problems since.
 

·
Registered
93 Allante, 06 CTS
Joined
·
723 Posts
2004CTS said:
Sure about that (have proof)? I've owned many and never had problems.
I had a side terminal fall out of my AC-Delco battery in my Tahoe. When I remarked to the guy at Autozone that I had never seen that before he said, "happens all the time".
 

·
Registered
Black the Darkside
Joined
·
22,415 Posts
Discussion Starter #19
FSU_Noles said:
I had a side terminal fall out of my AC-Delco battery in my Tahoe. When I remarked to the guy at Autozone that I had never seen that before he said, "happens all the time".
ME THINKS IF I NEED ANOTHER BATTERY I JUST MIGHT ANOTHER BRAND MYSELF.:yup:
 

·
Registered
Black the Darkside
Joined
·
22,415 Posts
Discussion Starter #20
Three days in the shop! I got it back today. They found nothing wrong..no drains on the battery and no shorts. Damn that gives you a sinking feeling! You know it's gonna happen again. But you can't fix what you can't find. It's intermittent. Anybody else experience anything like this?
 
1 - 20 of 34 Posts
Top