Cadillac Owners Forum banner

Urgent help. My car won’t start

1907 Views 16 Replies 5 Participants Last post by  HoosierCaddy
I have 2010 SRX. I received one remote from the dealer when I purchase the vehicle. I bought another one from eBay which was ready to program. I put the original one in the cup holder and used the key in driver side door. I twisted it 5 times and it showed me ready to program key #3.
Since I only have one key, I wanted to delete all the key fob programming and start fresh with the existed one and the one I bought from eBay.
After it showed me ready to program key #3, I pressed the start switch and the car was out of programming and showed “no key detected”
And now when I try to put the original fob in the cup holder and twist the key in driver’s door 5 times, it still shows no key detected.
I’m able to lock and unlock my car with the key but it won’t start. It keeps showing me “key not detected”
Please help. I’m unable to start my car
1 - 1 of 17 Posts
When I programmed the spare I got off ebay the programming did not go smoothly either. The DIC went black on me and I was not sure it worked. The new fob didn't want to do anything at first. Went back a half hour later and car still didn't recognize it. For the heck of it I tried to lock and unlock the doors. That worked and then everything worked. That fob though is a bit wonky. Sometimes the car won't recognize it until I cycle it through lock/unlock first. Not a big deal for a spare, but if it was my primary this might get annoying. I've read others say there was a delay before the car decided to recognize a newly programmed fob, so hang in there. Seems like a little patience is warranted here.
  • Like
Reactions: 1
1 - 1 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.