Cadillac Owners Forum banner

1181 - 1200 of 1215 Posts

·
Registered
Joined
·
1 Posts
Hello again..I,m having the same problem,with clock touchpad,non-responsive,as stated in my post yesterday.When I go to config,and when you,try just the clock button,it beeps only once,and the buttons are non-responsive?Car is running,starting,great otherwise..No non start issues..I may battery and fuse disconnect tommorrow,for an extended period,to drain all capacitors etc..and see what happens..Everything on the touch screen appears to work,BUT THE CLOCK?
same here mine started after the car sat for about 2 month's
 

·
Registered
97 DeVille Base - SOLD, 2004 SRX, 2008 STS
Joined
·
25 Posts
The clock adjust screen will come up after touching and holding for a couple seconds the clock area on the screen but none of the adjusting "buttons" are functional.

This is happening after an issue last evening where the car would not start until after disconnecting and reconnecting the battery.

Even then I had to put the keyless start switch in accessory mode first and then was able to start the car.

Any ideas on the clock adjust issue as well as what may have caused the "no start" issue. Thanks in advance for any help.
As this has been written up so many times because every STS owner at some point hours though this. When the car gets code to 100k miles and the battery is disconnected for any reason then battery is reconnected the clock will not work again. I was lucky enough that after the clock stopped working about 4 months later the clock display would reappear and could be adjusted but the date function cannot be adjusted. This has happened twice. Finally enough was enough and I contacted a buddy that works with this kind of equipment and he wrote me a program that restore the clock and the date function normal again. I tested it today and everyone works out it supposed to. Cost me a little bit, something that should have been covered in a recall since all owners had the same issue. But I'm just glad I have my clock and date functions working again.
 

·
Registered
2009 STS, V6, AWD
Joined
·
75 Posts
As this has been written up so many times because every STS owner at some point hours though this. When the car gets code to 100k miles and the battery is disconnected for any reason then battery is reconnected the clock will not work again. I was lucky enough that after the clock stopped working about 4 months later the clock display would reappear and could be adjusted but the date function cannot be adjusted. This has happened twice. Finally enough was enough and I contacted a buddy that works with this kind of equipment and he wrote me a program that restore the clock and the date function normal again. I tested it today and everyone works out it supposed to. Cost me a little bit, something that should have been covered in a recall since all owners had the same issue. But I'm just glad I have my clock and date functions working again.
If you've been reading here, then you know there is a fix for that which has been posted numerous times. Unless you have a different issue, it has nothing to do with how many miles are on the car but rather when the power is disconnected and the nav firmware needs to be updated so that it can find the satellites. Check out the bulletin attached.
 

Attachments

·
Registered
Cadillac STS 3.6 2006
Joined
·
85 Posts
If you've been reading here, then you know there is a fix for that which has been posted numerous times. Unless you have a different issue, it has nothing to do with how many miles are on the car but rather when the power is disconnected and the nav firmware needs to be updated so that it can find the satellites. Check out the bulletin attached.
I've read the attached bulletin, but what do I do?
My Cadillac is a 2006 STS?
I don't know exactly what my unit is called?
Can I use the same file as for model 2008?
 

·
Registered
Cadillac STS 3.6 2006
Joined
·
85 Posts
I have a 2005 Cadillac STS 3.6 V6 and successfully updated navigation with 2008 update. The clock finally works again and date is correct. I used Window 10 pro to unzip file and burn to CD-R disk. The file took a few minutes to load on navigation.
It sounds promising, did you use the procedure described in the bulletin?
Do you know if your navigation may have been updated before ??
 

·
Registered
2009 STS, V6, AWD
Joined
·
75 Posts
I've read the attached bulletin, but what do I do?
My Cadillac is a 2006 STS?
I don't know exactly what my unit is called?
Can I use the same file as for model 2008?
Some posters here have used the 08 link in the service bulletin. Here is another one:

#1,156

The 08 file was used for on 05 in that case.
 

·
Registered
Cadillac STS 3.6 2006
Joined
·
85 Posts
Thanks guys, I just did this with my 2006 STS and it worked like a charm. I used the 2008 update. My daughter is thrilled to have the clock working in her car again!!
578845

578846

578847

578848
preparing 10.jpg
preparing 30.jpg
preparing 90.jpg
Ur igen.jpg

Thanks to GM, now my watch is working again on my CADILLAC STS 2006
 

·
Registered
2009 STS, V6, AWD
Joined
·
75 Posts
What you should know is that it was not GM that developed the fix but rather Denso, the company that made the nav unit. The links are in the service bulletin so the mechanics know what to do. Densonavi is the person in this forum you should be thanking. See past posts from around October/November for more information.
 

·
Registered
Cadillac STS 3.6 2006
Joined
·
85 Posts
What you should know is that it was not GM that developed the fix but rather Denso, the company that made the nav unit. The links are in the service bulletin so the mechanics know what to do. Densonavi is the person in this forum you should be thanking. See past posts from around October/November for more information.
sorry, so many thanks to Denso and Densonavi or those who made the updates to our cars so we can see the clock again. ;-)
 

·
Registered
2009 STS, V6, AWD
Joined
·
75 Posts
No problem, just wanted you to know the source of the fix. Here is a post from Densonavi from around four months ago that discusses the history:

We have the fix validated and approved by GM. Just waiting for DENSO internal approval of the validation we did. Should be next week, 2 weeks max. There was a couple road blocks we had to get through so it took longer than it should to get the SW approved. Fix will be for 05-10 Corvette, should work on 05? Grand Prix but it wasn’t validated. STS 08-11. Unfortunately for earlier STS models, we couldn’t find the SW. Through our testing we found that the clock will correct itself on 8/16/2020. The date will not be correct but the time will be. This is good news and bad because it delayed the approval process. Some groups at DENSO wanted to cancel the SW but GM rejected this. Sorry this took a year but with so many different groups involved and different ideas, directions, it took a long time. This fix was not moving forward until some Corvette owner sent a letter to the DENSO President and he told management to give GM a fix. You may want to send him a thank you letter.

#761
 

·
Registered
2005 cadillac STS AWD 1SG
Joined
·
531 Posts
Does anyone who used 08 fix at 05-06 cars has lockpick from Coastal eTech (unlock video in motion)? Wondering if update could interrupt work of this device, cause it was different versions for different model years...
 

·
Registered
2008 STS Northstar RWD, 2000 Trans Am WS6 6 spd, 1968 LeMans convertible 6.6
Joined
·
198 Posts

·
Registered
Joined
·
5 Posts
View attachment 578845 Hi Wolff I've got a 2006 STS as well, I downloaded the file, unzipped it, burned the LOADING:KWI on to a CD and........... nothing happens. The NAV systems tells me it is not a Navigation disk.
What am I doing wrong/different from what you did.
View attachment 578846
View attachment 578847
View attachment 578848 View attachment 578845 View attachment 578846 View attachment 578847 View attachment 578848
Thanks to GM, now my watch is working again on my CADILLAC STS 2006
 

·
Registered
Joined
·
5 Posts
I downloaded the file, unzipped it , buned LOADING.KWI on to a DVD+R and.......... nothing happens. The NAV system tells me it is not a NAV Map Disc. ????
 

·
Registered
Cadillac STS 3.6 2006
Joined
·
85 Posts
When I first saw your post yesterday, I thought you were from the future because 11:44 AM was about 3 hours away still, for me here on Sunday morning March 1st. I almost PM'd you for the lotto numbers!
That's because we Danes are too fast for you in the States ;-)
 
1181 - 1200 of 1215 Posts
Top