Cadillac Owners Forum banner

701 - 720 of 723 Posts

·
Registered
Joined
·
1 Posts
Put a new battery in my 06 sts-v. Cant adjust clock, buttons on adjust screen are not highlighted and non functional. Tried shutting radio off and disconnected battery, nothing WTF
 

·
Registered
Joined
·
3,126 Posts
Put a new battery in my 06 sts-v. Cant adjust clock, buttons on adjust screen are not highlighted and non functional. Tried shutting radio off and disconnected battery, nothing WTF
So...... Before you posted this, did you actually read through the thread? This would be a really good start so we don't rehash what everyone has been complaining about for 6+ months.
 

·
Registered
Joined
·
215 Posts
Well guys, there is a chance this business of Denso working on a fix and needing outside help might be legit.

I asked "densonavi" to PM me his corporate email address before I sent him additional contact information, and he did. LinkedIn confirms there is a Denso engineer, in Detroit, with his name. Unfortunately he needs another Model Year than mine.

I'm slightly more optimistic than I was this time yesterday.

Of course, I will protect his identity and WILL NOT SHARE his email or name. Do not ask.
 

·
Registered
Joined
·
4 Posts
Considering this affects every STS with navigation, it would be pretty GD easy for a dealer to assist.

DENSO: "Hey, we are working on a firmware fix which will apply to about a zillion GM vehicles"

LOCAL DETRIOT DEALER: "That sounds cool, but where do we come into the equation?"

DENSO: "We need cars to validate the fix and want to leverage your customer base. Would you mind reaching out to a few of customers with navigation STS's to see if they'd be willing to beta test new firmware, for free? We would also be willing to provide $50 Visa gift cards."

DEALER: "Absolutely, but what do we get out of it?"

DENSO: "Once we finalize the firmware, we will recommend a TSB be issued taking 1.0 hours of labor and issue one DVD per dealer. The procedure is super easy and fixes both the clock and GPS spool up time. Customers wanting to fix these issues will gladly fork over $100+ and it is something which would take you less than 10 minutes, resulting in a win-win. We'll also give you $5,000 because Denso is being paid tons of money to R&D a 10+ year old system."

DEALER: "Sounds great we have 20 customers in our file"

(edited 2 words for clarity)
Your creativity is amusing. Yes, we probably will/did provide gift cards to get access to the vehicles. We are pursuing an option that will be free to the customer. This is still in the works.
 

·
Registered
Joined
·
66 Posts
I asked "densonavi" to PM me his corporate email address before I sent him additional contact information, and he did. LinkedIn confirms there is a Denso engineer, in Detroit, with his name.

Unfortunately he needs another Model Year than mine.....
Which model/year (s) does he need?
 

·
Registered
Joined
·
3,126 Posts
Firmware isn’t identical for all years though I’m sure.
I'm sure this has played a role in complicating things, but some code/routines may be common between them. Firmware definitely isn't the same across all years as I discovered when I added speed alert/speed advisory (not to mention the obvious differences with 2005-07). I'm wondering if there aren't some hardware differences that may also play into it. I am curious as to whether the update will replace only certain segments of code but otherwise leave the rest unchanged. I know that when I first purchased my 08, the nav screen was damaged. The GM Electronic Service Center told me that it was no longer available for my particular radio model number and I would be looking at an entire replacement. Since they actually service radios and clusters, I had no reason to disbelieve them. Unlike perhaps a dealer that can only replace the entire unit.
 

·
Registered
Joined
·
2,657 Posts
Your creativity is amusing. Yes, we probably will/did provide gift cards to get access to the vehicles. We are pursuing an option that will be free to the customer. This is still in the works.
Well guys, there is a chance this business of Denso working on a fix and needing outside help might be legit.

I asked "densonavi" to PM me his corporate email address before I sent him additional contact information, and he did. LinkedIn confirms there is a Denso engineer, in Detroit, with his name. Unfortunately he needs another Model Year than mine.

I'm slightly more optimistic than I was this time yesterday.

Of course, I will protect his identity and WILL NOT SHARE his email or name. Do not ask.
Good news. Thanks.
 

·
Registered
Joined
·
1 Posts
Hello, I've been following the thread for some time but had nothing new to contribute. Now I do; my '06 STS magically got the Clock and Nav back but the date of Dec 2000.
My guess is there is no secret formula to achieve this, it is most likely a particular satellite signal that can trigger it or perhaps a fail safe timer?
As I have done nothing different with the car since it went out.
The only thing that happened before it came back was loose contacts in my fob caused me to not be able to open the door. So if there is a trick it would be that, you have nothing to lose by trying to open the door unfobbed and see if triggering the security some how resets something in the unit. Highly unlikely but there was really nothing else it's been the exact same driving routine since I lost the clock. So you can rest assured that if unfobbed entry attempt doesn't bring your clock back then nothing you can do will. Whatever is at play is out of our hands. I won't be disconnecting my battery again!
I am in Vancouver, BC Canada if that matters to you.
 

·
Registered
Joined
·
3,126 Posts
Hello, I've been following the thread for some time but had nothing new to contribute. Now I do; my '06 STS magically got the Clock and Nav back but the date of Dec 2000.
This has happened for a few lucky people but I'm "next door" in Alberta and my clock is still out. I've been fortunate in that navigation has worked almost flawlessly throughout, despite almost always having a red line across my GPS flag. I can only think of one instance where my map was not even close to my actual location. Some others have reported consistent mapping difficulties.
 

·
Registered
Joined
·
3 Posts
The clock adjust screen will come up after touching and holding for a couple seconds the clock area on the screen but none of the adjusting "buttons" are functional.

This is happening after an issue last evening where the car would not start until after disconnecting and reconnecting the battery.

Even then I had to put the keyless start switch in accessory mode first and then was able to start the car.

Any ideas on the clock adjust issue as well as what may have caused the "no start" issue. Thanks in advance for any help.
there is a tsb its a known issue my 05 sts is the same way
 

·
Registered
Joined
·
3 Posts
This has happened for a few lucky people but I'm "next door" in Alberta and my clock is still out. I've been fortunate in that navigation has worked almost flawlessly throughout, despite almost always having a red line across my GPS flag. I can only think of one instance where my map was not even close to my actual location. Some others have reported consistent mapping difficulties.
the red line is there if you are not getting signal from at least 3 sat to work
 

·
Registered
Joined
·
3,126 Posts
the red line is there if you are not getting signal from at least 3 sat to work
Yes, that was my understanding. What surprises me though is how I almost always have a red flag, yet my mapping and navigation work perfectly (with the exception of one trip).
 

·
Registered
Joined
·
2,657 Posts
Probably mostly doing dead reckoning. With the occasional GPS fix.

Not sure why yours is better at it than some others. Maybe a difference in years and firmware, or related to your location/specific roads.

I'm hoping to put off losing power to mine until the update is out.
 

·
Registered
Joined
·
3,126 Posts
Probably mostly doing dead reckoning. With the occasional GPS fix.

Not sure why yours is better at it than some others. Maybe a difference in years and firmware, or related to your location/specific roads.

I'm hoping to put off losing power to mine until the update is out.
I suspect you're correct. Once in a while (from what I notice, very infrequently) the red flag disappears and this likely helps. I've got a 2010 radio in my 2008 and I know the firmware is different, I just don't know all the specific differences.
 
701 - 720 of 723 Posts
About this Discussion
722 Replies
104 Participants
carter's_sts
Top