Cadillac Owners Forum banner

261 - 280 of 1179 Posts

·
Premium Member
2006 STS V8 AWD, '95 Ford Ranger
Joined
·
28,957 Posts
Will try this procedure tomorrow. In the meantime, my car's an '06, and I don't have a map dvd anymore (I just use my smartphone like dkozloski does). Is there a PIN for my car? Is there a procedure that works that doesn't depend on the map being displayed?
I wouldn't have a smart phone stuck in my rear end if I had room for a sawmill. I use an old copy of Streets and Trips along with a DeLorme GPS module on a laptop for navigation. After I get there I manually set a waypoint for the next time. After I get across the border into Canada there is POI data for Canada that can be used.
 

·
Registered
Joined
·
1 Posts
I have a 2009 STS 3.6. After a few cold days at the end of January in Illinois. -50 with the windchill effect. My STS battery died. Replaced it with a new one and the clock is not working. It wasn’t working for about close to two months. One day miraculously it was working again. I have read it might of been a software issue. But it seems it’s working now on my STS.
 

·
Registered
06 STS-V & 06 STS 4 (sold 2016)
Joined
·
2,713 Posts
I have a 2009 STS 3.6. After a few cold days at the end of January in Illinois. -50 with the windchill effect. My STS battery died. Replaced it with a new one and the clock is not working. It wasn’t working for about close to two months. One day miraculously it was working again. I have read it might of been a software issue. But it seems it’s working now on my STS.
Is the date correct?
 

·
Premium Member
2006 STS V8 AWD, '95 Ford Ranger
Joined
·
28,957 Posts
FWIW, I drove mine for over ten years before I realized it even displayed a date. In NAV mode mine will flash a date for a couple of seconds if you press on the time display, otherwise you have to have the NAV turned off to see the date.
 

·
Registered
05 Stealth Gray CTS-V, 08 Light Platinum SRX V8, 05 White Diamond STS4 V8 1SG
Joined
·
2,047 Posts
Or is it timing chain/guide noise? Yes, in the V8.
 

·
Registered
96 STS; 09 STS4 N* Platinum w/1SG & PCZ
Joined
·
182 Posts
Yep, add me to the list. My right side mirror had been going into back up position all by itself, so I though I'd try resetting things. Disconnected the battery, touched pos to neg, let it sit for a while, and reconnected. No clock. Dang it. Called GM. Neither person knew anything. Suggested I take it to a dealer. I gave the second guy the Info Bulletin number and, gee, he had not seen that before. He still said to take it to a dealer. I have a call into my the service department to see if they have any new info.
 

·
Registered
2008 STS V8
Joined
·
94 Posts
Call GM back and insist they enter it into their computer and issue you a ticket number. Also, don't waste your time calling the dealer because they can't help you until GM gets off their ass and issues a fix. The more cases they have open, the better chance we have of GM doing the right thing. Calling the dealer does not open a case.
 

·
Registered
96 STS; 09 STS4 N* Platinum w/1SG & PCZ
Joined
·
182 Posts
After discovering my clock is toast, I got into the diagnostic menu on the nav system. And sure enough, no satellite acquisition. No GPS signal at all. And, as we know, since the clock gets it's time from the GPS, ergo, no clock.

But, here is a question for everyone. How many of you who are experiencing this problem have purchased a nav disc on the black market? I did. I'm wondering if there is any connection between not purchasing a "real" gm disc for $180 and the trouble with the gps/clock? I understand that this issue is wide spread, across several GM lines. However, is it not realistic to think that there are lots of people who didn't want to spend $180 and got a disc off eBay for $15. And might those $15 discs be the problem?
 

·
Registered
96 STS; 09 STS4 N* Platinum w/1SG & PCZ
Joined
·
182 Posts
Hey Binky,

Yes, I understand that the perceived purpose of the disc is as you state, but it would not be hard to encode something on that disc that talks to the "system" or the gps side of things, so that only GM discs would keep things running correctly. Or is GM not that smart?
 

·
Registered
2006 STS V8 1SF RWD
Joined
·
6,469 Posts
I have a genuine 2010 GM NAV disc in my STS...alas no clock. Disc source, be it GM or illegitimate copy, is unrelated to the clock problem.
 

·
Registered
96 STS; 09 STS4 N* Platinum w/1SG & PCZ
Joined
·
182 Posts
curtc,

Well, your confirmation of the clock problem with a real GM disc blows my theory. And I thought I was being really smart. Sure is fun driving around with no clock and seeing myself in the middle of the lake ( according to the GPS).
 

·
Registered
2006 STS V8 1SF RWD
Joined
·
6,469 Posts
curtc,

Well, your confirmation of the clock problem with a real GM disc blows my theory. And I thought I was being really smart. Sure is fun driving around with no clock and seeing myself in the middle of the lake ( according to the GPS).
Aside from my clock not working my GPS seems to be OK. It does take a while for the GPS to get signal but it still tracks me fine on the map even when the GPS symbol with the red dash is there.
 

·
Registered
96 STS; 09 STS4 N* Platinum w/1SG & PCZ
Joined
·
182 Posts
Curtc,

I would bet that you are not getting signals, as indicated by the red dash in the GPS icon. Your map is using stored dead reckoning information. Try driving around in circles a couple of times and then head down the road and see what happens. Go into the nav diagnostic mode and you will likely see that there are no satellites acquired.
 

·
Registered
Joined
·
181 Posts
It was previously discussed that the issue we are all having with no clock also makes it take much longer to lock in the satellite signals it used to take me I would say just a couple minutes now it takes 20 to 30 " of driving to lock in the satellites and it seems I only get 2 now, I assume in the past it was finding more.
 

·
Registered
96 STS; 09 STS4 N* Platinum w/1SG & PCZ
Joined
·
182 Posts
I'm convinced that the issue is not with the clock at all. It is with the GPS and satellites. For the past three days, my map had me in Washington DC. I live just north of Seattle. No acquisition of satellites at all. No satellites, no clock. It's that simple.
 

·
Registered
2008 STS V8
Joined
·
94 Posts
Yeah, cuz the nav units in my other three vehicles (with clocks) work just fine. Gotta be the satellites, right?
 
261 - 280 of 1179 Posts
Top