Cadillac Owners Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey, I'm new to the forum. Hopefully, this is the best place to get some advice on this question.

Took my 2001 STS in for engine stalling and they replaced my crank sensor (the service guy new immediately what the problem was when I was describing the symptom). When I got the car back, the Twilight Sentinal that senses the ambient light seemed to allways keep my headlights on, even in bright daylight until I shut off the car! When I turn off the sentinal, the dash has the "headlights suggested" message come on while I'm driving in bright daylight.

Any clue what is causing this? Could they have messed something up when they reprogrammed the vehicle?
 

·
Registered
2005 CTS-V, 1994 Infiniti Q45
Joined
·
7,658 Posts
I suppose its possible they messed something up....... Maybe the sunlight sensor (i believe its the little black nubbin on the dash) is somehow messed up, causing the computer to think its dark all the time..... Thats my best guess.......
 

·
Registered
2005 CTS-V, 1994 Infiniti Q45
Joined
·
7,658 Posts
Oh yes, and welcome aboard....... Thanks for signing up...... How many problems have you had on your 01 STS......?
 

·
...Reloaded
'05 XLR
Joined
·
1,698 Posts
You know the customer service questionnaire postcard they leave in the car? They often toss it on top of the dash - it's not covering your light sensor, is it?

When my crank sensor went, they also knew right away from the symptoms and verified by diagnostics. And they told me it wasn't that common. :eek:
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Everyone,

1. Good news! I figured it out and feel kind of dumb. It seems that my car has rain-sense wipers. Evidently, the dealership had moved the wiper stalk to the intermittent mode, but since it was not raining, I did not know they were on. The owners manual states that if the wipers are on for more than 6 seconds and the Twilight-sentinel is on, that the lights will automatically come on. As soon as I turned the wiper switch off, the lights went off.

2. For the individual who wanted to know if I have had many problems with the car: I purchased it about 2 months ago as a "Certified Pre-Owned" off of the Sewell lot in Dallas (by the way, they have many very nice pre-owned Caddy's there). It had just under 30K miles and was in super condition and loaded to the max (it has every option except Navigation). I purchased the 6yr 100K extended factory warantee for another $1500. After about a month of driving, I had enough driving experience with it to know about a few minor issues.
A) Loose lower outside drivers door trim piece
B) Driver's seat belt tensioner sticks occasionally
C) Mild Highway shudder in the wheel - they ballanced the tires
D) Brake shudder - they turned the rotors

Last week it stalled twice, and I took it in and the crank sensor was replaced.

I really love the car, very comfortable and the perfect blend of upscale luxury and sport. Hopefully, this will be all that will ever need.
 

·
Registered
2005 CTS-V, 1994 Infiniti Q45
Joined
·
7,658 Posts
I wouldnt necessarily count on that.... But i wish you good luck, and I encourage you to post any question you may have!!!!
 

·
Watching the Watchers
Joined
·
5,959 Posts
rnail said:
Everyone,

1. Good news! I figured it out and feel kind of dumb. It seems that my car has rain-sense wipers. Evidently, the dealership had moved the wiper stalk to the intermittent mode, but since it was not raining, I did not know they were on. The owners manual states that if the wipers are on for more than 6 seconds and the Twilight-sentinel is on, that the lights will automatically come on. As soon as I turned the wiper switch off, the lights went off.

Dont feel dumb, same thing happened to me when I first got the car, there should be a dash light that illuminates when your wipers are on. I leave mine on accidentally all the time
 

·
Registered
'06 DTS Performance
Joined
·
204 Posts
Perfect post rnail!

This just started happening on my '97 yesterday. It was 90 degrees out and sun like nobody's business! Why were my lights on in twilight sentinal mode?

Thanks for posting the 'fix' to this. I have the rain sensor as well. I'm anxious to get home this afternoon and see if my wipers are set to the auto mode.

..rickko..
 

·
Registered
Joined
·
3 Posts
Hi Guys,
Well its 2010 and I am down here in New Zealand with a 2002 STS export i.e. imported from Japan to NZ Seville STS RHD and yes it does have the Aux Jacks in the glove box so I can run a DVD player into the Bose Screen. Great at Car shows. Yeap I am in Love....
Had this issue as high lighted here and it has fixed it. Turn the Wipers off, Do not leave on INT. I have an 82 Fleetwood Brougham D'Elegance as well. This forum is so good. Thank you very much for all the helpful information and if you are ever visiting NZ email me and we can catch up.

Cheers Mr ED
 
1 - 9 of 9 Posts
Top