Cadillac Owners Forum banner

1 - 20 of 29 Posts

·
Registered
2013 XTS
Joined
·
2,087 Posts
Discussion Starter #1
My right side turn signal is not working. I was thinking it's the flasher because I can hear a weak clicking but when I turn on the hazzards there is nothing on the right either. The car is a 2000 STS and I was wondering if the signal flashers are seperated from right and left rather than hazzard and signal ?
 

·
Registered
2013 XTS
Joined
·
2,087 Posts
Discussion Starter #3
It appears to be the flasher and it seems to be one unit under the upper dash. Problem is I can't get the dash up enough to see it and or remove it.
 

·
Registered
2013 XTS
Joined
·
2,087 Posts
Discussion Starter #4
Well I got the part ordered anyway from gmpart.com my dealer wanted 80 bucks and I got it for 53. The flasher on the seville is a part of the hazzard switch mine clearly has gone bad as I have no right side signal or flasher. Does anyone know a good way to get the dash cover off ?
 

·
Registered
1997 SLS
Joined
·
550 Posts
I changed my flasher 2 years ago (it was a dealer part) and you have to remove the outer cosmetic panel beneath steering column and then there's an inner panel to remove too. I had to put the front seat all the way back to get under there on my back (I'm not a big guy and small hands are helpful for this). The flasher is on a clip that you have to pull away from an inner hold-down hole about half way up the dash, and if I recall, it's more towards the driver's door. Just disconnect the old one from the harness, put on the new one and reverse the process. Well, put ignition to "on" first and make sure the signals work properly. Good luck.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,998 Posts
If one side works and the other doesn't, I doubt it is the flasher. I'd suspect a bad bulb, ground or socket.
 

·
Registered
2013 XTS
Joined
·
2,087 Posts
Discussion Starter #7
I can hear it clicking really weak on the right side but when I put on the left it is strong ?

Greg on the 2000 model it is a part of the hazzard switch right under the upper dash.
 

·
Registered
2013 XTS
Joined
·
2,087 Posts
Discussion Starter #8
All lights seem to be working. I went out and tried them however I can't tell the right because it dosn't flash. But all bulbs where on. The side light does still come on when I flip on the signal though. I may pull out the front assembly and take a peak at the bulb tonight.
 

·
Registered
1997 SLS
Joined
·
550 Posts

·
Registered
90 Eldo -SOLD-, 98 ETC -SOLD-, 86 XR4Ti Track Car, 07 Ranger
Joined
·
963 Posts
are you talking about your flasher relay because that's what it sounds like to me when I had weak/erratic then nonexistent turnsignals...
 

·
Registered
Cadillac
Joined
·
23 Posts
the amber bulb in the front has two fillaments dim for parking bright for flashing the flashing fillament could be burned out, not drawing enough current to make flasher operate, the hazzard flasher uses same fillament, could make it flash slower.
 

·
Registered
2013 XTS
Joined
·
2,087 Posts
Discussion Starter #12
the right signal is non existant and the hazzard only blinks on the left side. I can feel the flasher going very weak when the right signal is on. This is what leads me to believe it's the flasher. the right marker light still comes on when I put on the right signal as well.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,998 Posts
I don't think the flasher differentiates between left & right, but I could be wrong.
 

·
Registered
Cadillac
Joined
·
23 Posts
question, do you have any lights burning on right front or rear, when turn signal is on right turn, besides the side marker light,
 

·
Registered
Cadillac
Joined
·
23 Posts
if you left the right turn signal on when you tested the hazzard flashers the right side would not flash, because the turn signal had control of the curcuit.
 

·
Registered
Cadillac
Joined
·
23 Posts
Ranger is right you loose both sides if flasher goes, my 97 would slow down and then stop flashing , if had to wait for light at turn. but lights would be light they just didn't flash.
 

·
Registered
99 Seville STS, 08 STS4 N* 1SG F55
Joined
·
3,516 Posts
It appears to be the flasher and it seems to be one unit under the upper dash. Problem is I can't get the dash up enough to see it and or remove it.
You must remove the A-pillar trim. Pry out gently starting at the top. Once the A-pillar trim has been removed you have enough room to lift the dash pad up to disengage the clips that hold it at the base of the windshield and pull it out. Don't forget to disconnect the speaker wiring - should be one connector in the center.
 

·
Registered
2013 XTS
Joined
·
2,087 Posts
Discussion Starter #18
Well I went out this morning and tried replacing the front amber bulb. It was burned out by the way but the signal still dosn't work with the good bulb I put in it.
 

·
Registered
2013 XTS
Joined
·
2,087 Posts
Discussion Starter #19
Thanks for the help guys with getting the dash pad out. When the part comes I am going to fix it I hope.
 
1 - 20 of 29 Posts
Top