Cadillac Owners Forum banner

1 - 17 of 17 Posts

·
2009 STS 4.6
2009 STS 4.6
Joined
·
22 Posts
Discussion Starter #1
I have a 2009 sts rwd 4.6 and I have a question about the transmission mount. The car has a clunking type situation when under light acceleration but under hard acceleration it seems fine. I have replaced the rear differential bushings and both engine mounts it also has a new driveshaft carrier bushing/bearing. What I’m wondering is should the mount be able to move by hand? When I apply brakes it moves the shifter back and when I floor it it moves forward. Also when I hit bumps it bounces a little. I’m sorry ordering of this is normal for these types of mounts or not. I know it’s not a simple block like most and the rubber is soft. But should it have and play? There are no cracks in it.
 

·
Registered
2006 STS4 4.6L
Joined
·
536 Posts
Someone correct me if I'm wrong for believing the transmission mount is a metal bracket with a rubber insert. I don't believe it is the same part as the motor mount.
 

·
2009 STS 4.6
2009 STS 4.6
Joined
·
22 Posts
Discussion Starter #3
It is a metal bracket with a rubber bumper on it. I just ordered an acdelco from amazon for $108.
 

·
Registered
2005 cadillac STS AWD 1SG
Joined
·
526 Posts
Caatknip
I have completly the same problem at my 2005 awd 4.6. Motor mounts replaced back at 2014,replaced transmission mount this summer (by the way it hard to diagnose, but when i pull it out - rubber fall off )) but it doesn't change a thing.
Still have this bounce and clunking issue. Nobody doesn't have a clue.
 

·
2009 STS 4.6
2009 STS 4.6
Joined
·
22 Posts
Discussion Starter #6
Caatknip
I have completly the same problem at my 2005 awd 4.6. Motor mounts replaced back at 2014,replaced transmission mount this summer (by the way it hard to diagnose, but when i pull it out - rubber fall off )) but it doesn't change a thing.
Still have this bounce and clunking issue. Nobody doesn't have a clue.
Did you check differential bushing?
 

·
Registered
2005 cadillac STS AWD 1SG
Joined
·
526 Posts
Did you check differential bushing?
Yes, i replaced it just after motor mounts and checked recently - looks fine.....but one of my motor mount plays more than it should, I think...
just a theory: all mounts should be good all together, otherwise it bounce and wears out others.
 

·
Registered
2006 STS4 4.6L
Joined
·
536 Posts
Sorry for all the questions, trying to clarify.
You can move the transmission mount by grabbing the driveshaft? Do you see movement in both the transmission and the mount or just in the mount?
 

·
2009 STS 4.6
2009 STS 4.6
Joined
·
22 Posts
Discussion Starter #10
The transmission is tight to the mount. The mount is just flexible. That’s what I’m trying to figure out. The transmission mount on these cars isn’t like most others. It has a lot more rubber but I’m trying to figure out if it should be hard rubber and has deteriorated or if it’s pliable in the first place.
 

·
Registered
2006 STS4 4.6L
Joined
·
536 Posts
Well it should be at least semi-pliable, although too soft or deformed will have obvious effects. Do you see any cracks or deformation in it? I haven't heard of many people having to replace the mount but everything has some sort of lifetime limit.
 

·
Registered
2006 STS4 4.6L
Joined
·
536 Posts
Well if the transmission mount is flexing too much it goes without saying that it's no good. I honestly don't think it should be flexing or shifting enough to even notice.
 

·
Registered
2006 V6 STS RWD
Joined
·
281 Posts
Good lord, an official PDF that, "Dey all do dat". Saves you the trouble of driving to the dealer to get a bowl of chocolate pudding. :ROFLMAO:
 
1 - 17 of 17 Posts
Top