Cadillac Owners Forum banner

1 - 2 of 2 Posts

·
Registered
1993 STS, 1997 STS, 2002 SLS, 2007 CTS 3.6
Joined
·
378 Posts
Discussion Starter #1
I will try to make this short... I was driving on Tuesday got on it pretty hard to pass someone and check engine light came on and tranny dropped down to second. My understanding is thats normal if there is a problem with transmission. I limped it to where I had to go shut down waited a bit started up and kinda babied it...no problems.

Later that night on the way home when i got up to about 60mph it slipped down again. Pulled over waited re started and it did it again almost immediatly.

I ran the codes and can not find P0110, P083. Anyone have any ideas on these? I have been told chances are it is the shift solenoids...kinda hoping one of the two codes will be that. The other codes are P073,P094.

I refuse to take this to the Caddy dealer in town as I have been warned they will just try to shove a new tranny down my throat.

Comments? Suggestions?
Thanks!
 

·
Registered
Joined
·
4 Posts
Tranny

I had the same problem you did last year. I was on the road to Lynchburg, VA. I took it into the Lynchburg dealership for a diagnosis. They said that the fluid was burned, and I needed a new transaxle for $3,100. I told them to put it outside. I took it to a local transmission shop. They replaced the three solenoids @ $400. There was nothing wrong with the fluid or the transaxle other than one solenoid, I went ahead and replaced all three. I wrote Cadillac corporate and complained. The dealer called within the hour and offered my $65 diagnostic fee back. Crooks.
I have another problem now in that when the car shifts down into overdrive at 45mph is flutters and hesitates. As the speed increases it goes away. If anyone has an idea, let me know.

Thanks, Ed
'94 Concours
 
1 - 2 of 2 Posts
Top