Cadillac Owners Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I bought a simply beautiful '84 Seville with low miles and perfect interior and paint. After replacing the belts and tires and having it serviced, tonight I took it out for a spin. There was a faint red battery light on in the dash, which is all digital. I drove anyway, then on the way home, the block of lights for the miles per gallon, a/c, etc all just went out, then the other dash lights slowly dimmed and so did the outside lights. This is like 10pm and by then I'm one mile from home. I kept driving, although the motor started sputtering. Long story short, the car behind me was flashing their lights, so I know mine went down to nothing, then it died and I coasted into the driveway with no power whatsoever and a dead car.

Any hints? I hadn't driven the car at night and assumed the battery light was just on a blitz since I hadn't seen it previously.

Thanks,
Si
 

·
Registered
Joined
·
6 Posts
sounds like your alternator is not working. maybe you have a bad connection or you might need to replace your alternator. It seems you car was running off of your battery but when you turned on your headlights your battery ran down fast due to the high current draw of the headlights. your battery probably kept wearing down until it hardly had enough power to fire your plugs (hence the sputtering), and then finally went dead.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
scottan said:
sounds like your alternator is not working. maybe you have a bad connection or you might need to replace your alternator. It seems you car was running off of your battery but when you turned on your headlights your battery ran down fast due to the high current draw of the headlights. your battery probably kept wearing down until it hardly had enough power to fire your plugs (hence the sputtering), and then finally went dead.
:bouncy: You are right! Replaced the alternator this morning and it is back to normal. The strange thing is that this morning it started like nothing had happened. I drove to a parts store that diagnoses battery and alternator and starter and it was dead by the time I got there, which meant another tow, but luckily, I got a new one put on and drove her home. Thank you for your help! :worship:

Si
 
1 - 3 of 3 Posts
Top