Cadillac Owners Forum banner

1 - 10 of 10 Posts

·
Registered
97 Deville
Joined
·
8 Posts
Discussion Starter #1
I had code p0340 pop up so I changed the CMP and both CKP's. Engine still idles rough though when I get it up to speed it seems to go away. Reading the forums I see that it is supposed to have a "relearn" procedure performed. I take it to a Chevy dealer (mistake) he tells me there is no relearn procedure for a 97. Is this true? If no relearn procedure how hard is it to time the N*'s?
 

·
Registered
2001 Seville STS, 1990 Seville (RIP), 1972 Sedan Deville
Joined
·
26,323 Posts
Always list code definitions along with codes.

P0340 - CMP sensor circuit

Was the engine running rough before the code was set?
Is the code still current?
Any other codes?

Timing is controlled by the PCM and not adjustable.

There is a relearn for the CKPs, but it's almost never necessary. If there was an issue you'd be getting a related code.
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,268 Posts
Just bought it. Ran fine for about 3 days, then it started the rough idle. Only code is the 340.
Could PCM be bad?
----------------------
did you use genuine ACDelco sensors -
or el-cheapos?
 

·
Registered
97 Deville
Joined
·
8 Posts
Discussion Starter #5
Took to Cadillac dealership they had it for 3 days diagnosing.
1st they thought it was ignition module, put new one on did not work. No charge.
2nd PCM, new one on did not work. No charge.
3rd diagnosed timing issue. Remove engine and fix. $2,200.00
So this is the summary: Chevrolet dealership fixed head gaskets in January 2013 but put it back together wrong. Little lady I bought it from went to a nursing home in March of 2013, the car sent her over the edge!
Dealership in Springfield, MO. took great care of us and I am really impressed by their dedication, would highly recommend them to anyone in need. While they had it out they checked everything over and gave it a clean bill of health. 96,000 on it and the journey begins.
Thanks to all that helped out.
 

·
Registered
2001 Seville STS, 1990 Seville (RIP), 1972 Sedan Deville
Joined
·
26,323 Posts
So there was a valve timing issue? That would cause running issues constantly, not intermittently.
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
68,441 Posts
If the cams and/or timing was "reversed" you would have certain mechanical mayhem. Something's not right, though.

The RE sprocket also has the pulse trigger button for the CMP hall effect sensor - timing and rotation TDC reference.

RE, RI, LE, LI - Right/Left Exhaust/Intake sprockets.
 

Attachments

·
Registered
97 Deville
Joined
·
8 Posts
Discussion Starter #9
According to Cadillac dealership both exhaust cam gears installed 180 deg out. and replaced ignition coil. The only issue I still have is the service engine light is still on. Any thoughts?
 
1 - 10 of 10 Posts
Top