Cadillac Owners Forum banner

1 - 20 of 23 Posts

·
Registered
'04 SRX
Joined
·
84 Posts
Discussion Starter #1
Have an '04 with 39K miles.
I have had two occurances of throttle-body problems in the last two months. First: on my way from Florida to Ohio and ended up spending the night in West Virginia as my SRX was towed to a dealer, I was given a rental (warranty paid) and came back through a week later to get my SRX. They replaced the entire throttle-body.
Symptoms were: car was revving high, only changed gear once when I let off of throttle, and then wouldn't go over about 40... and took forever to get there... pressing accelerator did nothing.
Then on this past Friday, only a about 7 weeks after getting the new throttle-body, we saw the same symptoms. This time, the local dealer "replaced a bent pin".

So... has anyone else seen this issue?
 

·
Registered
Joined
·
858 Posts
Not yet ....
Ask the dealer where the pin is located and what it does. Seems the throttle body is one big assembly with sealed moving parts.
We have a couple of Cad techs participate from time to time hope they jump in on this one. What say you ewill3?
 

·
Registered
99 Eldo ETC 04 SRX V8 AWD 13 XTS
Joined
·
202 Posts
I had emissions recall done and ever since at times idle doesn't want to go to 650 rpm wants to stay at 1000rpm also makes you have to brake hard to stop . This is 04 V8 checked with dealer they said no check engine light no problem this seem to be getting to be common answer any more!!!!!!!!!!
 

·
Registered
2005 SRX N*V8 RWD; 1999 DeVille Concours
Joined
·
514 Posts
nstar said:
I had emissions recall done and ever since at times idle doesn't want to go to 650 rpm wants to stay at 1000rpm also makes you have to brake hard to stop . This is 04 V8 checked with dealer they said no check engine light no problem this seem to be getting to be common answer any more!!!!!!!!!!
Q? Was this above "emissions recall" the 06516 "recall" or the "yellow top" bulletin GM ID# 1556462 or the reflash bulletin 04-07-30-044 as widely discussed ECM reflash/ updates that "detune" SRX N*V8s.
Notes on "reflashing" under many titles on this forum by John d (12-02-05) and others up to the present time reveal that dealer/ ECM reflash originally intended to reduce problems (?) in the multiple differentials of AWDs also creates many undesirable impacts - including slow throttle back-off response together with harder braking - for N*V8 SRX vehicles as well as prefromance degradations.
 

·
Registered
99 Eldo ETC 04 SRX V8 AWD 13 XTS
Joined
·
202 Posts
The recall that was done is number 06503 suppose to deal with evap emission canister purge solenoid. This is a 04 V8 AWD .
 

·
Registered
99 Eldo ETC 04 SRX V8 AWD 13 XTS
Joined
·
202 Posts
The recall I recieved said I didn't have to do it but that it would effect the warranty on vehicle if recall wasn't done and with the warranty work that has had to be done on this vehicle I wouldn't want to effect any further work that has to be done.
 

·
Registered
2005 SRX N*V8 RWD; 1999 DeVille Concours
Joined
·
514 Posts
Were the 06503 or the 06516 "recalls" sent from the Cad factory or GM, from your dealers, or just "matter-of-factly" noted by your dealer when you go in for service??
Can the Cad factory really just cancel your warranty without the factory "specifically notifying" you directly and 'splaining why "the recall" is required vs ??
 

·
Registered
'04 SRX
Joined
·
84 Posts
Discussion Starter #11
So... I had to revive this one... since my last post... I saw the problem again... and they replaced my throttle body again stating "there was a dead spot in the TPS (throttle position sensor). That was about 2 months ago... and guess what happened again.
Fourth time! Today throttle went away... I stopped vehicle, turned it off, restarted... engine started loping with "engine reduced power warning".
It is now time for me to escalate this issue into GM management. I have a strong preference for GM vehicles, always have... this is the 6th GM I have owned : 3 Chevy, 1 Oldsmobile, 1 Buick... and now 1 Cadillac. I do not expect this experience out of GM's premium line.
 

·
Registered
2005 SRX AWD V8
Joined
·
204 Posts
Isn't it time they admit that something is affecting the throttle body rather than the throttle body itself? Anyways, I would freak out. I have been having this problem that is similar to yours. My car drives fine one day, then sporatically I have the following problem: The engine looses power from 1/4 pedal to about full throttle. The problem goes away with time, but not simply from a restart. They cannot figure out what the problem is, had 8 engine codes the first time. They reset the computer, and gave it back. Had the same problem, this time they "cleaned all connections" and gave it back with a special "black box" to record all parameters the computer doesn't record. My car is a lease, and if they don't fix it soon, I am giving it back.
 

·
Registered
'04 SRX
Joined
·
84 Posts
Discussion Starter #13
They replaced the ECM in mine this time... let's hope I am done now. There isn't much more! If this doesn't fix it... then the only thing left is the wiring harness.
 

·
Registered
'04 SRX
Joined
·
84 Posts
Discussion Starter #14
OK... so the problem is back again. This makes the fifth time for the issue. Now I believe that the dealership has enlisted direct GM assistance because I was told that they placed it on "Tech hold". I am at 48,500 miles... and will be driving about 1600 miles between Friday and the beginning of the year. Ergo, I will be beyond factory bumper-to-bumper warrantee... nice, huh?
History of this thing is:
1.) Replace throttle body
2.) Fix bent pin
3.) Replace throttle body
4.) Replace computer
 

·
Registered
91 Allante (gone), 06 SRX (gone)
Joined
·
4,396 Posts
I think you should leave your car at the dealer while they sort the problem out and they should give you a loaded 07 SRX AWD V8 for the next couple weeks.
 

·
Registered
2010 Perf 3.0,AWD, 2011 Yukon Denali,(403HP), had 04 SRX
Joined
·
1,160 Posts
OK... so the problem is back again. This makes the fifth time for the issue. Now I believe that the dealership has enlisted direct GM assistance because I was told that they placed it on "Tech hold". I am at 48,500 miles... and will be driving about 1600 miles between Friday and the beginning of the year. Ergo, I will be beyond factory bumper-to-bumper warrantee... nice, huh?
History of this thing is:
1.) Replace throttle body
2.) Fix bent pin
3.) Replace throttle body
4.) Replace computer

Hi! I have not had this either w/V-8, 21K miles,AWD ETC. I've had all recalls done except the new "emission" one.

Seems they're trying hard and replacing some very costly items for you (gotta give the "devil" his due!) However you deserve a loaner, extended warranty (you said they have you on "Tech-Hold", good) and if it continues, a buy back under Lemon Law.

Stick with it! I've been to Lexus dealers and they also seen some similar stuff! All hi-tech autos can have this, unfortunately! If it was common, this forum would show it and probably resolve it. Some members have 100K miles on their '04 Srx! (little comfort to you!):annoyed:
Good luck and please keep us informed. Many Thks!
 

·
Registered
'04 SRX
Joined
·
84 Posts
Discussion Starter #17
They replaced a connector. Had it on "GM tech hold" for several days... whatever that means (I believe that the local dealer enlisted GM engineering help). I have since driven FL to OH and back with no issues. I guess we will see if it is corrected if I get through the next 3 months or so of normal driving.
 

·
Registered
2004 SRX, 2005 CTS
Joined
·
13 Posts
KMO,

Had to bring this post back out. I'm having exactly the same problems as you did with your 04 SRX. I'm wondering if you still have the vechicle and if so have they corrected all the issues? I'm searching for any help anyone else has with these issues. I've still got 10 months left on my lease and I'm over the factory warranty (I've got 52K on my SRX). :mad:

I've been back and forth with my Dealer Service Department and GM and Cadillac for the last month without any solid results. :thepan: So far they've replaced the Throttle body 3 times, ECM once and they just replaced the Catalytic converter.
 

·
Registered
'04 SRX
Joined
·
84 Posts
Discussion Starter #19
I have seen no further issues with the vehicle after the final correction (connector replacement).
 

·
Registered
Joined
·
858 Posts
I have seen no further issues with the vehicle after the final correction (connector replacement).
Does the repair order specify by a part number, wiring harness number or name which connector and can you describe it's location?
Thanks.
 
1 - 20 of 23 Posts
Top