Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 3 of 3 Posts

·
Registered
2003 Cadillac CTS
Joined
·
29 Posts
Discussion Starter · #1 ·
Im not sure if anyone else posted about this procedure but it worked for my 03 cts.
when getting tps codes causing the beloved "reduced Engine Power" what i did was took the clips off the sensor housing (leaving the throttle body attached to the intake and uncliped the wiring housing.

nothing falls apart when removing the sensor cover but be careful because there is small parts in there you dont want to accidentally hit,
when its apart take some electrical cleaner and spray the clips and connecters as well as the tps circuit board and connectors and let sit for about 30 mins.
put it all back together and just cycle the key once (auto min and max position learn on these)
mine was acting up everyday and now its been 3 weeks since i cleaned mine and no problems (non serviceable my but)
 

·
Registered
2003 CTS "Ebony Maria" 2005 Cadillac STS "Grace"
Joined
·
6,414 Posts
this is something that we suggest and is definitely worth trying...but a few forum members and one i can think of off top (MaxFloss) has tried this but to no avail. this is more less a temporary fix, but i do hope that it works for you and you no longer have any issues, but just be cautious
 

·
Registered
2003 Cadillac CTS
Joined
·
29 Posts
Discussion Starter · #3 ·
well it got to the point that it was everytime i drove the car a block i limped home at 5km/h so i had to do something lol i think the problem is where the 4 tabs slide on the tps board gunk gets built up on the tabs but thats just my guess. but so far so good (i run an brake and tune shop btw)
 
1 - 3 of 3 Posts
Top