Cadillac Owners Forum banner

1 - 20 of 29 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 08 Cadillac DTS that I love but have recently come into a few problems. The third break light bar has a few lights out, and I hear that I am going to have to have the whole bar replaced? Also, the left speaker comes in and out when driving which is annoying and now my darn warning signal comes on and reads Lane Departure needs service. Anyone have any of these problems occur with their DTS?
 

·
Registered
2011 cadillac dts
Joined
·
556 Posts
Yes the 3rd light have tobe change as one unit because is led look for one on ebay could find them thereon the speaker take the door panel of maybe the connection to the speaker is loose.

----------

On the depacher lane issue try to turn it off . Look at the manual on how to.
 
Joined
·
12,821 Posts
Re: Third break light out...

Ninibtrue, would you consider taking your DTS to a Cadillac dealer for service? It would be a great next step, and please let me know if you would like any assistance working for your dealership towards a resolution. I'm available via email at [email protected]!

Best,

Katie
Cadillac Customer Service
 

·
Registered
2013 XTS Premium
Joined
·
214 Posts
Re: Third break light out...

I was able to buy one from gmparts direct or similar site for around $100. It was very difficult to get the old one off, the mounting studs that are attached to the brake lamp assembly in a way that they break off from the plastic as soon as you try to loosen the mounting nut on the underside of the trunk, so the studs are just spinning in place. Not fun
 

·
Registered
2006 Cadillac DTS (Black Raven)
Joined
·
298 Posts
Re: Third break light out...

Don't buy used... A dealer put a used one on my DTS when I bought it and It cracked and the some of the lights went out too...

Bought a brand new one and its perfect!
 

·
Registered
2009 DTS II
Joined
·
166 Posts
Re: Third break light out...

Don't buy used... A dealer put a used one on my DTS when I bought it and It cracked and the some of the lights went out too...

Bought a brand new one and its perfect!
so you would suggest not to get a used one? So ebay would be ok? I have a few ones out in mine as well.
 

·
Registered
2005 CTS/ 2008 DTS/ 2008 STS V8 N*/ 2011 CTS4 ALL W/D Pearl
Joined
·
688 Posts
I was taken for $295 at the Caddy dealer :rant2: two years ago. I wish I new about this board and ebay back then. Sorry to get off topic I know I will be in trouble for not starting a new thread but Sub, in you're albums you have a picture of a tranny fill cap off showing no fluid. I have read you're posts explaining in great accurate detail on why no fluid is visible looking down or on dip stick when cold ( not running ). My question is do you know why on the dip stick it has a cold reading about ( bottom to half way up the stick saying cold then the rest to almost the top saying hot ). The only thing I can think of is it is for people that would not run the engine ( drive far enough or long enough to get a proper reading of hot. I hope this doesn't sound to stupid. Sorry for asking this in this thread.:duck:
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
70,672 Posts
^^^ Exactly the reason for two sets of marks on the 4T80E stick - the fluid expands when sufficiently hot - COLD is to get the fill level in the ballpark for post-work startup, then you do final after-test drive hot level checks.
 

·
Registered
2005 CTS/ 2008 DTS/ 2008 STS V8 N*/ 2011 CTS4 ALL W/D Pearl
Joined
·
688 Posts
I put it in myself, that was just for the light. It was very easy, someone said they had a little trouble mine was a breeze and I hold a pen for a living.
 

·
Registered
Joined
·
1 Posts
Tom's Caddy said:
I put it in myself, that was just for the light. It was very easy, someone said they had a little trouble mine was a breeze and I hold a pen for a living.
Indeed to know the proper way of removing the fasteners from the trunk appliqué to get at the third brake light and where can I get new fasteners?
 

·
Registered
2008 DTS Lux III
Joined
·
338 Posts
I bought one (brand new) in May on Ebay for about $160, plus shipping. Put it on myself in about a half hour. It was fairly simple. Just don't over tighten the nuts when installing the new one. These units seem to go out faster than they should. I suspect the slamming of the trunk has something to do with it. Speculation on my part, but I'm now careful when lowering the trunk lid.
 
1 - 20 of 29 Posts
Top