Cadillac Owners Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #5
no I only have the original key. Before it turned off. I noticed that the stereo started acting up. I adjuted the time but when driving the stereo changed back to factory settings i noticed it because the radio station changed as well as the time (Clock). Also the temp and fuel gauges didnt work. drove it like that for a week. After the week the cur just shuts off before making a stop. Tried to turn on no luck, Its been 2 weeks and still cant turn it on. Also my message center says. service theft. Tried doing the 30 min relearn process but the security light will never turns off. At this point i think it is the ECM. Allready replaced crank and fuel filter. I have spark at coils and fuel pressure. But it just doesnt turnn on

----------

Also checked mechanic checked timing belt and it seems ok
 

·
Registered
Joined
·
24 Posts
Discussion Starter #8
My battery says 12.5 if it starts going down I tricle charge it. Not sure what to replace the bcm or the ecm.
 

·
Registered
2003 CTS Luxury/Sport package
Joined
·
722 Posts
Sounds exactly like what happened to me when my ecm went out. Good chance the key will get stuck in the ignition in the on position. Hate to be the bearer of bad news.

----------

Most likely the anti theft module is causing a command failure. Which is an internal failure on the ecm.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #10
Ok so based on your guys help. Im am going to have my ecm checked. I know this guy. he works on reprograming (FLASH) ECM. Do you guys think the
ECM can be reprogrames or flashed. If it is. This guy says he can do it and make my car run. He Only charges me 100 dlls for the work. Im thinking of giving it a try and hopefully it turns on. This will happen today monday at afternoon. Ill keep you guys updated.

Thank for your help
 

·
Registered
2003 CTS Luxury/Sport package
Joined
·
722 Posts
I don't think a flash will fix the problem. If anything hell pry disable your theft system completely to get the car to run. There really is no easy way around an ecm failure.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #12
Ok I understand If he can make my car run without the theft system ill drive it like that for this week. This is my only way of trnsportation so I guess ill drive it until my next paycheck to buy a new ECM and reprogram it. Im still whaiting on the guy.
 

·
Registered
2003 CTS Luxury/Sport package
Joined
·
722 Posts
Well hopefully for your sake he knows what he's doing and he can get you back on the road for the time being.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #14
UPDATE

Well hello. So it turns out that the ecm is ok. But the guy that scanned it says there is a short somewhere in the car and that may be the reason for the gauges not working but that it had nothing to do with the car not turning on. He said to take the car to his shop tomorrow
So after the guy left I checked my torque again. checked the fuel leve and saw it said it had 20% of fuel in it. I decided to take a walk to the nearest gasoline
station so the car had gas in case the guy turned it on.
So when i got home I put the gas in. and just to check tried to turn the car on one last time. And bam. IT TURNED ON

So I guess It needed fuel. Not sure if torque (THE APP) had been reading the fuel level incorrectly. But my car works now.

This did not fix the fuel and gauge problem. but the car is on now. Now I will try to fix that issue. I have seen alot of threads about this gauge problem but have not seen anybody resolve it. Hopefully I will.

Ill keep you guys updated in case of a solution
 
1 - 14 of 14 Posts
Top