Cadillac Owners Forum banner

1 - 17 of 17 Posts

·
Registered
Cadillac SRX 2007
Joined
·
29 Posts
Discussion Starter #1
Anyone have had any problems with the theft alarm going off without any reason? This happens to me now and then and the only way to fix it is by turning off the motion sensor before locking the car. My local dealer have ordered a new indoor sensor for the alarm, hope that solves the problem...
 

·
Registered
Cadillac SRX 2007
Joined
·
29 Posts
Discussion Starter #3
They have located it to the theft intrusion sensor, located in the roof lamp console between driver and passenger. If the sensor is hanging loose everyting works fine, but if it is mounted in the console it will cause a false activation of the alarm. Right now the intrusion sensor is disconnected, they said two months ago that they will contact GM but nothing has happened.

For the CTS I know there is an old bulletin about this:
04-08-56-003A Rear Dome Lamp Console Mounting Loose, False Activation of Theft System (Replace Rear Console, Transfer Theft Intrusion Snesor to New Console) September 12, 2006
 

·
Registered
2009 SRX-4 Sport / TriCoatWhite
Joined
·
1,185 Posts
I didn't know there was a theft alarm... Meaning, I have never had mine go off!

Hmmm.. now I am wondering if mine works.... I'll have to do the window down / lock car / reach in open door - test to see!

Mattias: Maybe you have a mouse living in your car - setting off the motion detectors! :)
 

·
Registered
Cadillac SRX 2007
Joined
·
29 Posts
Discussion Starter #5
Is this some special equipment for the European cars or what? Because otherwise this problem should be more visible on this forum. My dealer had three cars right now with the same problem and there is no solution to it right now...I don't think they can blame it on mouses running around in swedish Cadillacs :)
 

·
Registered
2005 SRX N*V8 RWD; 1999 DeVille Concours
Joined
·
514 Posts
Anyone have had any problems with the theft alarm going off without any reason? This happens to me now and then and the only way to fix it is by turning off the motion sensor before locking the car. My local dealer have ordered a new indoor sensor for the alarm, hope that solves the problem...
We have experienced our theft alarm going off for no apparent reason, but finally isolated it to an apparently sensitive "alarm button" on one of the remotes. By leaving the sensitive remote at home, the alarm has not since gone off.
It may be worth your testing as it is a simple test.
Good luck.
 

·
Registered
2007 SRX V8 AWD Sport
Joined
·
184 Posts
I feel like I should update this thread just in case it would help some people.
I recently got tons of false intrusion detections with alarm going off even in the middle of the night !
Unplugged the intrusion sensor and nights became silent again.
Intrusion sensor is located on overhead console. Part number is 15774715 and is pretty expensive ! 816€ listed at Paris stealership ! Got it @ buy gm parts worldwide for $400. You might want to leave without replacing it. As an car enthusiast, I hate owning a baby with something that doesn't work as expected.





As you can see, batch# of the old part is "test" (!). Batch of new part is "1895"
 

·
Registered
2007 SRX V6
Joined
·
44 Posts
Replaced my 2001 STS with 2008 SRX 3,6 with 38K miles and i must say that have been to the dealer number of times already. Since the car is still under warranty they have replaced all shocks, both xenons, one taillamp and couple of smaller things. But seems that saga continues since alarm went off yesterday couple of times and same thing today so at the moment i need to turn off motion sensor every time before i lock the car. Seems like similar problem described on this thread....so i will call dealer tomorrow and see what they're suggesting...but for a 3 months i have seen them already too many times....
 

·
Registered
2004 cadillac srx v8
Joined
·
50 Posts
wiz hi it's vetters and hubby. Today I got battery changed and now alarm wont disable to get key out and hazards flashing when press brake. called rippy said never heard of. now in dash says service security and hazards on ...in driveway. Starts..and tried disconnect restart thing..didnt work. please help.
 

·
Registered
05 srx awd v6 (gone), '07 GXP, 2010 li'l red wagon 3.6
Joined
·
3,177 Posts
You may have some DTCs. Sometimes when this happens, clearing the codes will reset things to normal.Worth a try.
 

·
Registered
2007 SRX V6
Joined
·
44 Posts
Hi

a little update on this. Today 6 am that damn alarm went off again. Before today, last time when it occurred was last summer. then i called a shop where a service my car and they suggested that i check a switch under the hood. With intense sun hood could bend a little and when the switch doesn't connect to hood it prompts alarm. Bent the switch little bit, made sure that it connects and no more alarms. Since today. But i'm pretty sure that this time it's not hood related since it's like 8C outside at the moment and no sun. :-(
 

·
Registered
Joined
·
1 Posts
Hi there!

Where is the switch under the hood located? My srx is equipped with the custom alarm system that calls on my phone and says that the hood is open.
Thats why the alarm goes off. Didn't find the switch from the first glance.
Going to look for it tomorrow much more thoroughly thou
 

·
Registered
2008 SRX Sport Pkg
Joined
·
1,172 Posts
Theft alarm can go off under several conditions. If the battery is marginal or low, it can think that it is being tampered with. Also, if the temperature drops very sharply in a short time, the alarm sensor might trip. In some cases, you may get a message on the DIC saying "Theft attempted" or words to that effect. Lastly, if someone truly tried to enter the vehicle in an unauthorized manner.
 

·
Registered
CTS 3.2
Joined
·
12 Posts
Hello, may I ask if there's a motion sensor switch on a 2003 CTS? I would love to turn it off because of the above problem. Thanks
 

·
Registered
05 srx awd v6 (gone), '07 GXP, 2010 li'l red wagon 3.6
Joined
·
3,177 Posts
Intrusion sensor is in dome lamp assy.
 

·
Registered
1999 Deville, 1992 Corvette, 1993 K1500
Joined
·
16 Posts
On my car once the alarm has been activated it will go off after a minute or so. Then it will go off everytime you re-start the car. Until you lock the door with the Fob and then unlock the door with the Fob. (If your worried about the Fob not working try with window down) LOL That re-sets the system.
 

·
Registered
Joined
·
1 Posts
On my car once the alarm has been activated it will go off after a minute or so. Then it will go off everytime you re-start the car. Until you lock the door with the Fob and then unlock the door with the Fob. (If your worried about the Fob not working try with window down) LOL That re-sets the system.
thank you. my alarm went off when i tried starting. Now, after locking and unlocking it starts without an alarm. Doors will not actually lock or unlock, but at least i can use the car. I will continue charging my dead battery.
 
1 - 17 of 17 Posts
Top