Cadillac Owners Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
So I just rebuilt this transmission myself out of my 1970 cadillac deville and off the line from a stop it shifts perfectly. But when i come to a stop and right away try to take off again, it shifts vs soft with very low shift points. But if i come to a stop for about 20 seconds then take off it shifts fine. I checked fuild level with both the dip stick and unbolting the pan to see if it was just above the pan rail. I also replaced the fluid and have to pull the trans coming up to fix a small leak. I checked that vaccum is getting to the modulator which is a new adjustable unit and i even did a line pressure test with nothing to find out of line. So at first I thought the trans was too full and it was foaming the oil but it wasnt. Then i thought maybe the pump was going out but nope, passed the entire 1970 service manual checks with flying colors. Does anyone have any idea what it going on?
 

·
Registered
95 FWB 81SDV 96 FWB 94 Fleetwood
Joined
·
1,733 Posts
I had this problem years ago and trying to remember. It has to be something is sticking. The first thing would be to change the govenor. You could try taking it out and cleaning it with brake or carb cleaner
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
I have a good running th425, will the governor switch over if mine is not reusable? Though could it be the modulator sticking or a valve in the valve body sticking. I just want to know if I should stop driving it.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Ok I have found that the th425 governor is different and I took the governor out and the gear snapped off while I was taking it out. I cleaned the valve and ordered a new gear.
 
1 - 5 of 5 Posts
Top