Cadillac Owners Forum banner

1 - 15 of 15 Posts

·
Registered
99 STS
Joined
·
93 Posts
Discussion Starter #1 (Edited)
I have 99 Seville STS. 148,000 miles. Very nice and well maintained. Only code is B1343-Air Inlet Door Movement. I replaced busted Pressure Tank with a brand new one. Now I'm getting "Check Coolant Level" on DIC. Coolant level is good. So, I changed the sensor to the old one. I'm still getting "Check Coolant Level". Voltage is good. 11 volts with key on and goes up to 13 when I start engine. I disconnected battery cables to reset everything. Still getting "Check Coolant Level". Float seems to work properly. I'm thinking defective part maybe? Any ideas?
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,781 Posts
Re: Pressure Tank Sensor

Defective float is all I can think of based on what you've said.
 

·
Registered
99 STS
Joined
·
93 Posts
Discussion Starter #3
Re: Pressure Tank Sensor

I'm thinking the same. Float moves up and down just fine based on coolant level but I think there's a magnet or something in the float that is defective. I'm open to any more ideas though.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,781 Posts
Re: Pressure Tank Sensor

If you are getting the warning only after replacing the surge tank, it has to be the float or the sensor. Where did you buy the tank and what brand was it?
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,268 Posts
Re: Pressure Tank Sensor

I have 99 Seville STS. 148,000 miles. Very nice and well maintained. Only code is B1343-Air Inlet Door Movement. I replaced busted Pressure Tank with a brand new one. Now I'm getting "Check Coolant Level" on DIC. Coolant level is good. So, I changed the sensor to the old one. I'm still getting "Check Coolant Level". Voltage is good. 11 volts with key on and goes up to 13 when I start engine. I disconnected battery cables to reset everything. Still getting "Check Coolant Level". Float seems to work properly. I'm thinking defective part maybe? Any ideas?
---------------------------
Voltage is good.
11 volts with key on
a fully charged battery will have 12.6 volts - engine off -
anything below 12 volts is considered dead -

and goes up to 13 when I start engine.
voltage with engine running should be 14.2 to 15.2 -
 

·
Registered
99 STS
Joined
·
93 Posts
Discussion Starter #7
Re: Pressure Tank Sensor

O'Reillys. $160 Not sure of brand but looks identical to old one. Receipt doesn't say brand. It is warranted though.

----------

Battery voltage on DIC says 14.2 The voltage I was talking about is from a Voltage meter I used on sensor plugin to see if it was getting fire.
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
68,441 Posts
Re: Pressure Tank Sensor

You can get the surge tanks through Amazon for about $57, shipped, including level sensor.
 

·
Registered
99 STS
Joined
·
93 Posts
Discussion Starter #9 (Edited)
I've never been a smart shopper! LOL I'll check around on my next purchase.

----------

Now that I've explained my bad choice of words on the voltage. Are we back to it being either a bad sensor or float?
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,781 Posts
Yeah, I gotta go with a sensor or float. Just can't imagine what else it could be.

Try unplugging the sensor connector and see what happens. Then bend a paper clip and plug it into the connect or making contact with both pins. I'm guessing that will shut off the message. If so, replace the tank.
 

·
Registered
99 STS
Joined
·
93 Posts
Discussion Starter #11
I used paper clip to make contact with both pins last night. And, yes, the message went away. O'Reilly's said they'll replace tank. I'll replace tank and update my results in a few days. Thanks Ranger!
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
68,441 Posts
I know you've seen this in your surge tank, but that green float with enclosed magnet should travel up (level OK) and down (level low) about 3/4". Turn your new surge tank upside down a few times to check that the float actually moves.

This 2002 Seville surge tank looks distorted - camera lens .................
 

Attachments

·
Registered
99 STS
Joined
·
93 Posts
Discussion Starter #14
I took the new surge tank off and yes the float was defective. The float would travel from the bottom all the way to the top (about 6 inches) when turned upside down. As Submariner stated, it should travel less than an inch. O'Reilly warranted it and gave me a replacement. Check Coolant Level message is now gone. Thanks to Submariner and Ranger for you expert help!
 

·
Registered
98 DeVille, 97 DeVille d'Elegance
Joined
·
7,345 Posts
Boy that can be aggravating when new parts are bad out of the box. Glad you got it fixed and parts store took care of you.
 
1 - 15 of 15 Posts
Top