Cadillac Owners Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
196 Posts
Discussion Starter · #1 ·
96 deville- i will be at idle and it will just all of a sudden shut off, it starts right back up every time, but it will just suddenly stall, no spuddering no nothing, it just shuts off, is this common or has this happened to someone else before? and whats wierd is when it stalls the only light that comes on is the oil light, but the oil level is fine and all that, no other check engine light or nothing comes on when it stalls....HELP! :worship:
 

·
Super Moderator
2010 DTS
Joined
·
88,980 Posts
Clogged filter is unlikely. That would manifest itself at high fuel demands first, not at idle.

If you are getting knocking and pinging, try cleaning the EGR valve. The Northstar has a very effective knock sensor (if it is working), so you should never hear a knock. Octain booster will be a band aid at best.

Cranks sensors are not too hard to do...... so I hear. I have never had the pleasure.
 

·
Cadillac Technician
none
Joined
·
11,038 Posts
I identified those in the other topic you started, at least some of them.

Sounds like crank sensors to me also.
If you knew where they were I would tell you to look at them and tell me if the top one was tan. If it is you need to replace them.
The new ones have a top one that is gray. Replace them both.
Also it looks like you have a theft deterrent problem, probably the wires breaking inside the steering column. That requires replacement of a lock cylinder and 2 new keys matched to the pellet to the old key.
 

·
Registered
Joined
·
2,246 Posts
hogstamogsta said:
ok i will look, is one of the crank sensors behind the harmonic balancer? and wouldnt it throw a code if that was the case?
No, they're near the oil filter.

Here's your code: "P1599 - Engine Stall or Near Stall Detected"

When one or more crank sensors is flakey, the computer thinks the engine just shut off for some reason...... so it stops everything... and then your engine really DOES shut off.

But, your "P1632 - Theft Deterrent Fuel Disable Signal Received"
Raises some flags with me... What happens if it's running and that happens? Is that possible? Does it do anything? Somebody with a OBDII manual look that code up, and see what the deal is... Your stalling might be due to a bad key or something..
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top