Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
Cadillac 1993 Deville 4.9, 1991 Eldorado Touring Coupe
Joined
·
370 Posts
Discussion Starter #1
1993 Deville 4.9 . Running very good except in the last month on 3 occasions , She stumbled under acceleration on highway on ramps all 3 times.

Common denominator was moderate acceleration while turning right. She will bog,lose speed and stumble for about 5 to 7 seconds, but not stall.....Then kick in and go.

Oxygen sensor is disconnected. I went to replace it and cracked a 7/8 oxygen sensor socket which i presumed was low quality even though i knew the sensor would not come out easily and resumed attempt to remove using a deep 7/8 so i cut the wires. ( no need to call me dumb here, i know already...but i thought second attempt would not fail)

Using a Craftsman 7/8 only resulted in a 1/2 drive U joint tearing apart (Craftsman also) so the old sensor still in until i get it replaced by someone else..Just disconnected.

Not sure if all the stumbling started before or after the sensor incident but at least one time i know for sure was after, but thought i would mention it as it is the only engine issue i am aware of. May or may not have anything to do with the stumbling which only occurs in the manner i explained. Any ideas or thoughts? And anyone in Southern NH or Northern MA want to take a crack at removing a very stubborn 02 sensor ? :)
 

·
Registered
2008 SRX
Joined
·
403 Posts
1993 Deville 4.9 . Running very good except in the last month on 3 occasions , She stumbled under acceleration on highway on ramps all 3 times.

Common denominator was moderate acceleration while turning right. She will bog,lose speed and stumble for about 5 to 7 seconds, but not stall.....Then kick in and go.
What was the fuel level when this happened? It sound like tank baffles that have cracked. Most noticeable under 5 gallons.
 

·
Registered
Cadillac 1993 Deville 4.9, 1991 Eldorado Touring Coupe
Joined
·
370 Posts
Discussion Starter #3
Thanks for replying!. Im not sure about fuel level at the time, But at about 6 gals or so i usually fill back up so it had at least that.
 

·
Registered
93 Sedan Deville 4.9L
Joined
·
1,005 Posts
no o2 sensor may be causing you to run very rich, which may cause stumbling; seems like your fuel mileage would take a huge kick though.

Have you tried anything like pb blaster or other penetrating oils to loosen it up? I forgot how i removed my sensor, I know i didnt use a o2 socket. IIRC I used locking pliers and just really tightened them on and turned it.
 

·
Registered
Cadillac 1993 Deville 4.9, 1991 Eldorado Touring Coupe
Joined
·
370 Posts
Discussion Starter #5
Thanks for reply! Yes gas mileage is very bad right now so im not wanting to put this off any longer.

I`ll give the PB blaster a try and some locking pliers before giving up and bringing it in. I hate to do that, I know they will complain how long it took to do and hit me with a huge labor bill.

I had a breaker bar on a 2 foot extension with a 2 foot length of pipe over the bar. The little bugger never budged and ate the first socket and a craftsman universal. The exhaust system was flexing like heck too...Was fearful any more force than that would break something in the exhaust....But i`ll give your suggestions a try.
Thanks!
 
1 - 5 of 5 Posts
Top