Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
Registered
cts?
Joined
·
187 Posts
Discussion Starter #1
I got an 03 cts, now my dic is stuck at -40 degrees and wont budge, also says possible ice condition when i start the car, i'm guessing the message is in relation to the temp. Now my question is where is the temp sensor located, and is there anything else i should check, i would like to avoid the dealer if possible since i'm out of warranty.

Thanks.
 

·
Registered
cts?
Joined
·
187 Posts
Discussion Starter #4
Look out the window. Do you see snow?
You have to be kidding me......

Its definitely not -40, i just wanna know where the outside temp sensor is located and how to test it to see if its good, or is it something else that went wrong.

I guess its hard to get any real help on here, people just like to be smart-ass's.
 

·
Premium Member
2006 STS V8 AWD, '95 Ford Ranger
Joined
·
28,970 Posts
On an '06 STS the ambient air temperature sensor is locate near the hood latch mechanism in front of the radiator. My guess is that it's unplugged.
 
X

·
Guest
Joined
·
0 Posts
at least you can find a small amount of humor in this defect....

that is pretty funny.

In all seriousness, I have no idea though. Good luck on the hunt!
 

·
Registered
Joined
·
27 Posts
If it is showing -40, it is either unplugged, a wire is cut, or the sensor itself has failed. It is located on the hood latch support, behind the grille. The HVAC system will substitute a "dummy" value in it's computations, but you might see some goofy temperature control situations. The engine does not use this sensor for it's operating control, it has its own.
 

·
Registered
cts?
Joined
·
187 Posts
Discussion Starter #8
Well, got in my car this morning and it started working fine, i think it just needed time to reset or somehting...
 
1 - 8 of 8 Posts
Top