Cadillac Owners Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
I have Cadillac Seville Sts 4.6 northstar,winter time start running very good!
one second and car runningn,now summer time + weather not start good and
casoline smell! i parking warm hall winter time couple times and there same problem,
is that engine somewhere sensor where give weather warm or cold,if engine is stop
5 min,start very good but maybe half hour not,i dont understand?! i change spark
plugs and air filter! i think the engine gets too much fuel to the start running???

[email protected]

Finland
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,793 Posts
Re: Cadillac STS not start running if weather is warm or engine is very warm!

Update your profile to show your year and model.

Check for a leaky FPR.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
Re: Cadillac STS not start running if weather is warm or engine is very warm!

my car is 2000 Seville STS,engine is same like 1999,i check yesterday leaky FPR.
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
68,513 Posts
Re: STS not start running if weather is warm or engine is very warm!

OK - It appears that you have a 1999 model year car registered as a "2000" - very common in Europe. If your engine has spark plug wires and 4 visible coils it is a 1999 model and that's the year you need to buy parts for.

The 1999 engine is NOT - nowhere near - the same as the 2000 and later.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #5
Re: STS not start running if weather is warm or engine is very warm!

what kind sensor "smell"outside temperature and where it is engine,i mean what sensor give instruction
computer how mutch give casoline engine,i think,is engine gold or warm give too mutch casoline,always
smell after started and engine run casoline!
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
68,513 Posts
Re: STS not start running if weather is warm or engine is very warm!

The Ambient Temperature Sensor is attached to the hood latch brace in front of the A/C condenser/radiator. 2-wire connector. May get moisture inside - if it is not reading correctly now - it has a DIC readout.

If your engine exhaust smells of gasoline you may have either a vacuum leak, an ignition miss or a sticky fuel injector.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,793 Posts
Re: STS not start running if weather is warm or engine is very warm!

Fuel delivery is controlled by the PCM with inputs from many sensors such as (but not limited to) TPS, ECT, MAF, MAP, Ambient temp, IAT, O2.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #8
Re: STS not start running if weather is warm or engine is very warm!

thanks for the replies! my car did not have any fault code, if it were so it would be easy to look for the fault of the importance of the sides below with electronics? if there's ignition enhancer? or something?
i mean under ignition coil,what is there?
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,793 Posts
Re: STS not start running if weather is warm or engine is very warm!

What is your fuel pressure?
 

·
Registered
Joined
·
20 Posts
Discussion Starter #11
Re: STS not start running if weather is warm or engine is very warm!

Fuel presure is 45psi when key is "on" position BUT maybe 2 second fuel presure fall 0 psi,where fuel presure
freyed?is problem,filter or FRP?i change new fuel pump,no any codes,i dont know what i do next!i started maybe
5-8 second and fuel presure rises 45Psi and then car running!please i need help now! my how know ended!
:-D

----------

Fuel presure is 45psi when key is "on" position BUT maybe 2 second fuel presure fall 0 psi,where fuel presure
freyed?is problem,filter or FRP?i change new fuel pump,no any codes,i dont know what i do next!i started maybe
5-8 second and fuel presure rises 45Psi and then car running!please i need help now! my how know ended!
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
68,513 Posts
Change the FPR - on the right rear leg of the fuel rail. (MAYBE the fuel pump assembly has a bad supply check valve, but that's doubtful.)

The 45 psi at Key: ON is perfect BUT that pressure should hold at about 40 psi after the 2 second fuel pump proveout/prime cycle. As soon as you turn the key to START the pump runs, fuel pressure again rises, and as the engine catches and comes up to idle speed the pump latches to constant RUN.

If the FPR inner diaphragm is even partially ruptured, with no fuel pump RUN the pressure drops instantly.

Click a thumbnail to enlarge, use your browser <-- to back out.
 

Attachments

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,793 Posts
Might want to check the FPR before replacing it, but if your pressure drops that fast, I'd almost bet the diaphragm has more than just slightly tear.
Just pull the vacuum line off of the FPR at idle and look for fuel at the nipple. There should be none.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #14
i check FPR pull off vacuun line,not coming fuel,but whether it could still be broken??fuel presure drops very fast!
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,793 Posts
Sounds more like a failed check valve at the pump to me.
 
1 - 15 of 15 Posts
Top