Cadillac Owners Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi all,

when I open the door of my STS everything tries to get into position for me. During that process the right mirror moves down (as if I would switch to the rear gear) and does that for quite a long period of time. So everytime the mirror points to the lowest possible position.

During that process it makes a popping sound when it reaches the lowest position as the motor continues to move downwards.

Is there any way to fix that problem?

I am wondering if there is a posiibility to reset my car with some kind of special key-combination.

Cheers!
 

·
Registered
2006 STS V8 1SF RWD
Joined
·
6,487 Posts
Bad mirror motor, car doesn't know the position of the mirror anymore so it gets confused. The guts of the mirror have to be replaced.

Sent from my Pixel 3 using Tapatalk
 

·
Registered
96 STS; 09 STS4 N* Platinum w/1SG & PCZ
Joined
·
191 Posts
Moppes,

I recently had the same issue. In the responses to my post ( Mirror Malfunction ) is a great tutorial with photos, about how to replace the mirror.
 

·
Registered
2014 ATS-4 2.0 (RIP), 2015 SRX4, 2008 STS4 V6
Joined
·
82 Posts
FWIW i had a similar problem with my driver side mirror. Turns out it was the control assembly on the door handle, as that piece had shorted out due to snowmelt and I replaced it, and no problems since.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Hey guys,

thank you all a lot for your quick replies!
It turned out that I simply had to "reboot" the car. Unplugging the battery and reconnecting it solved the problem for now.

A few things that seemed kind of strange vanished as well. For example, my navigation has gps-signal again. The steering wheel lock works again and I can start the car with the right button again (not the left one).

But there are still some misbehaviours which I am going to post separately. Perhaps there is anyone who feels inspired.

Cheers!
 

·
Registered
96 STS; 09 STS4 N* Platinum w/1SG & PCZ
Joined
·
191 Posts
moppes,

Did your clock start working too? I tried to re-boot to fix my mirror as well, but only succeeded in loosing my GPS and clock.......
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
moppes,

Did your clock start working too? I tried to re-boot to fix my mirror as well, but only succeeded in loosing my GPS and clock.......
Hi, no my clock still doesn't work. I coincidently saw another (32 pages!) thread here about that topic.
A bit weird, that the GPS flag on the map sometimes is deactivated (red cross) and sometimes it simply shows GPS. If I wasn't currently offering my car for sale I would install such a navtool device to get my Android Auto onto the screen.

Cheers, Moppes
 
1 - 7 of 7 Posts
Top