Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JULY's Ride of the Month Challenge!
1 - 8 of 8 Posts

·
Registered
04 XLR, 98 DeVille, 63 Coupe De Ville
Joined
·
122 Posts
Discussion Starter · #1 ·
Hi there,

no problems with the roof for about a year.
Operated it maybe 5 times since then, but now ... tadaaa ... it won't open.

The sequence:
Front tonneau opens, trunk opens, head latch is released, roof is retracted in the rear, BUT
now the rear tonneau will not come down / extend.
It looks like it's trying to extract the rear tonneau although it's already retracted.
And yes, when I pull it down by hand with the latches released it's extracting again.

So I took a Tech2 and looked for the sensors. All counts are fine, but the rear tonneau movement goes
in the wrong direction. Is this a valve problem?

I took a screen shot from my Tech2.

Really strange, don't know what to do next.
And one more thing that bothers me: In the Tech2 it says open or closed.
Is open = retracted or extended?

Thanks for help,
Sammy
 

Attachments

·
Registered
'02 ETC CE, '04 CTS-V, '04 XLR, '13 XTS Platinum
Joined
·
2,934 Posts
Open should be extended, closed should be retracted.

How do the counts look when trying to move? Do they vary at all? How do they compare to a baseline (the last time it worked) reading?

Have you performed a relearn?

Is your hydraulic reservoir level between the min/max lines?

Do you see the Rear Tonneau hydraulic manifold solenoid valve cycling on the Tech 2?
 

·
Registered
04 XLR, 98 DeVille, 63 Coupe De Ville
Joined
·
122 Posts
Discussion Starter · #3 ·
So the snapshot shows when the rear tonneau is retracted and it says "open" - could you open it?
Looks like it's the wrong status or confounded?

The counts increase or decrease when I move it by hand, sensors are working.
All counts are in reference to the baseline I noted last time expectI don't know what open or closed means, as I wrote before.
Only noted the range last time the roof worked fine and this is fine.

I can't do a relearn because it doesn't fullfil the cycle to open it all the way.

Reservoir level, power of the pump ... everything fine.
It's not weak at all - in the moment.

On my Tech2 it shows "Special features" and I can choose between Valve 1 to 5 and motor turn and reverse turn.
Which valve number would the one for the rear tonneau?
The service manual does not count this in numbers.

No DTCs, no errors in the roof module.


Open should be extended, closed should be retracted.

How do the counts look when trying to move? Do they vary at all? How do they compare to a baseline (the last time it worked) reading?

Have you performed a relearn?

Is your hydraulic reservoir level between the min/max lines?

Do you see the Rear Tonneau hydraulic manifold solenoid valve cycling on the Tech 2?
 

·
Registered
'02 ETC CE, '04 CTS-V, '04 XLR, '13 XTS Platinum
Joined
·
2,934 Posts
The five solenoid valves in the manifold control the following folding top components:

Valve #1: Front Tonneau and Windshield Header Latch
Valves #2 & 3: The folding top (one for each side's hydraulic cylinder.)
Valves #4 & 5: The Rear Decklid - same thing as above.

The Rear Tonneau is controlled directly by the hydraulic pump; all other valves must be closed.

CC
 

·
Registered
04 XLR, 98 DeVille, 63 Coupe De Ville
Joined
·
122 Posts
Discussion Starter · #5 ·
I see... so what should I do next?
If all valves are closed the motor seems to turn in wrong direction because it stll
tries to raise the rear tonneau instead of extending it.
 

·
Registered
'02 ETC CE, '04 CTS-V, '04 XLR, '13 XTS Platinum
Joined
·
2,934 Posts
Just so I better understand what you're describing, the Rear Tonneau doesn't raise - it extends, (to cover the space left after the top is stowed in the trunk) and retracts to allow the top to be stowed. Top up = Rear Tonneau is retracted. Top stowed, Rear Tonneau is extended.

A Relearn command ignores the previous values stored in the FTC and records new values as it commands each solenoid valve to operate. It assumes all components are operating correctly, meaning it bypasses safety protocols. If the pump isn't providing enough pressure, the Rear Tonneau won't move, (or may stall).

Have you opened the Hydraulic Bypass valve and moved the Rear Tonneau manually to ensure it isn't physically binding?

Also, verify the Hydraulic Bypass Valve is completely closed when operating normally to ensure full system pressure.

If you're sure all of these things are working, the Folding Top position sensor followed by the Rear Tonneau position sensor are suspect. They can be bad and not trigger a DTC.

Worse case scenario: You have a faulty FTC module, but that is way down on the list.

Visually inspect all associated cables and wiring for any abrasion, or flexing near connectors that could cause intermittent contact.

Clean the connector contacts of the two suspect position sensors just to eliminate that possibility.

CC
 

·
Registered
04 XLR, 98 DeVille, 63 Coupe De Ville
Joined
·
122 Posts
Discussion Starter · #7 ·
No. While opening procedure the rear tonneau cover will not extend, it stays retracted and it seems like the pump
is still trying to retract it even more, cause when I extend it by hand and then push the open button again
it goes back in the retracted position.
So the opening procedure stops here and I have to close the top again.

I can unlatch it from the retracted position and move it by hand, so it's not mechanically stuck.
 

·
Registered
04 XLR, 98 DeVille, 63 Coupe De Ville
Joined
·
122 Posts
Discussion Starter · #8 ·
Finally made it.
After putting the top several times in the open and closed position manually I could do a full relearn
with the Tech2. Working fine now.
 
1 - 8 of 8 Posts
Top