Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
Cadillac
Joined
·
6 Posts
Discussion Starter #1
Hey guys, 03 lade got a funny noise a few months back, situation is, went to make a right turn then steered back straight, get a strange pulse..almost like the steering stops then re-engages, thought nothing of it didnt happen for a while, this week same thing happened again several times, its almost like when you make a right turn then quickly turn back to straight the steering feels like it gives out..you feel a pulse and vibration and hear it..last about 1 second or 1.5 seconds then it corrects itself...fast forward two nights ago...service stability light chimes for the first time....havent seen it again yet...any ideas from anyone on the problem? thanks for any and all help
 

·
Registered
2008 SRX
Joined
·
403 Posts
when you make a right turn then quickly turn back to straight the steering feels like it gives out..you feel a pulse and vibration and hear it..
Ps gear valve will cause an erratic assist in left turns. Not sure what you would be hearing at the same time though. The gears also make a moan occasionally, usually no lack of assist related to the noise.
Stability light is another issue, need codes checked.
 
H

·
Guest
Joined
·
0 Posts
Your stability control uses the ABS wheel speed Sensors and the steering column sensor to know "when you need more stability". It sounds as if the front wheel speed sensor is sending bad info due to:
A) corrosion under the sensor causing erratic readings
B) front wheel bearing failing causing erratic readings
C) column sensor failing causing erratic readings

The GM dealer is the only place I know to have THOSE components tested. You can change any of these sensors yourself once you know which one it is. The "service stability" indicator is on because one of the sensors is not giving correct data, and the default mode is to disable the system. The noise and vibration are the system activating (it's usually unnoticed but now it's coming on at the wrong time.)
 

·
Registered
Cadillac
Joined
·
1 Posts
hey

just had the same prob..02 lade

took it to dealership

tell them to look for a brake pressure modulator valve asmbly
took them a few visits to figure this out...

covered under warrenty (was about 1500$)

let me know if it helps..
 
1 - 5 of 5 Posts
Top