Cadillac Owners Forum banner

1 - 20 of 27 Posts

·
Registered
06 CTS-V
Joined
·
20 Posts
Discussion Starter #1
Hi,

My 06 cts-v recently developed a problem with its tail lights. The brake lights, indicators and reverse lights work, as well as the headlights, however the parking lights don't illuminate out back when the headlights are on...

The third brake light activates as well when the brakes are pressed, the indicators work both front and back.

The hazard triangle no longer lights up at night, but when the hazards are on, the button flashes.

I've checked the bas fuse, the under hood tail light fuses. I haven't checked the bulbs yet, but they were replaced shortly after bought the car in August.

I recently had a Pioneer double din receiver installed in place of the factory nav. (I plan on doing the retain dic mod in the future) but to the best of my knowledge the tail lights still worked at that point (radio was installed Saturday)



Any input will be appreciated, I'll be buying the bulbs on the way to work tomorrow if the bulbs solve the issue i'll update the thread in the morning.


thanks
 

·
Registered
06 CTS Sport/Luxury package
Joined
·
9,802 Posts
Little confused...

You said that you are planing on retaining the DIC? What happened to the Navi that came with your V?

When the radio was installed, what was used for the Dimmer wire?

KOT
 

·
Registered
06 CTS-V
Joined
·
20 Posts
Discussion Starter #3
when the radio was installed we used the pac os2-cts module, the dimmer wire in the pac radio harness is connected to the pioneer nav unit.


the factory nav unit was removed due to broken dvd drive and the cd changer was making alot of noise...

Could it have something to do with that illumination wire? or a related fuse?

should the hazard triangle light up with the headlights on?
 

·
Registered
06 CTS-V
Joined
·
20 Posts
Discussion Starter #4
Bit of an update,

i forgot to mention, no license plate lights either,

checked the following fuses under the hood

LT Park
RT Park
Dimming
Dimmer

All fuses were fine.
 

·
Registered
06 CTS Sport/Luxury package
Joined
·
9,802 Posts
You said that you checked the BAS fuse, so you know about both fuse boxes under the rear seat. Did you happen to check the BAS mini relay?

Honestly, I do not remember if the hazard button lights up at night.

Just to be sure, the following are the lights that aren't working...

1) Rear parking lights when headlights are on. Is this the same whether you have the switch on, as well as in when it automatic mode?

2) License plate lights

3) Hazard button at night time

Did you check backup, turn signal, and what not?

KOT
 

·
Registered
06 CTS-V
Joined
·
20 Posts
Discussion Starter #6
Yup, Thats my issue too, i can't remember if it lights up either.

I checked both automatic mode, and headlights on, niether lights the parking lights or license plate lights.
I'm not too sure how to check the relay functioning, would i need that specific relay from cadillac or could i swap a similar one to check.


Reverse Lights, Turn Signals Brake lights (including center) all function correctly. Also, the Reverse lights do illuminate at night when i unlock the car, The Side (tail lights) dont flash anymore when unlocked either.
 

·
Registered
06 CTS Sport/Luxury package
Joined
·
9,802 Posts
Yes, you can swap with a known working one. I believe the fuel pump's relay is the same size. So swap those two and see if you can drive. If they aren't the same size, find one that is that you know that it's working.

When you press the hazard button, you say the button itself flash. But what about the outside lights?

KOT
 

·
Registered
06 CTS-V
Joined
·
20 Posts
Discussion Starter #8
Yes, you can swap with a known working one. I believe the fuel pump's relay is the same size. So swap those two and see if you can drive. If they aren't the same size, find one that is that you know that it's working.

When you press the hazard button, you say the button itself flash. But what about the outside lights?

KOT
The button flashes, as do the outside lights. It's really strange that its just the parking lamps essentially, I've had to drive at night with my hazards on to avoid getting pulled over...
 

·
Registered
06 CTS-V
Joined
·
20 Posts
Discussion Starter #9
So I just took the car by My Mechanic, (Chrysler Dealer) so he doesn't have any of the wiring diagrams available.

We swapped the Parking light and BAS relays and the lights still don't work, so the relays were fine, He said he didnt see a control signal at the parking lamp relay, nor power going to their fuses.

We noticed that the front parking lights also do not work.

Does anyone have a wiring diagram or schematics for this car, or any information how those relays are triggered.

My next step to diagnose is remove the pioneer NAV and test again, I'm wondering if the pac radio module is causing any issues, also if disconnecting that doesn't work i'll also try and reconnect the factory nav and see if that helps.
 

·
Premium Member
2006 STS V8 AWD, '95 Ford Ranger
Joined
·
28,963 Posts
Removing the stock radio did something to the serial bus. Not everything in these cars is directly switched. A lot of stuff is commanded on the serial bus.
 

·
Registered
03 CTS
Joined
·
34 Posts
Sounds like a bad ground to me. Also check where your lights fasten to the steel of the car. Thats where the lights ground to. Good luck
 

·
Registered
06 CTS-V
Joined
·
20 Posts
Discussion Starter #13
another update. disconnected the pioneer nav unit. the issue still persists. I also removed the drl module and cycled the power still didnt work.

if it was. an issue with the bcm would it throw a code?
 

·
Registered
06 CTS Sport/Luxury package
Joined
·
9,802 Posts
Not sure, I know from personal experience "small" misfires doesn't turn the light on. But when my mechanics $1,000 obd-2 reader is hooked up. It saw the misfires and told me what cylinder. But no check engine light, code or anything of that sort.

Were you able to test the drl module? Because it does much more than the drls. It actually provides power to all parking lights.

Using the diagram, I would hook up a little mock up of the car lights. Right left front and rear parking lights. And supply power to the module. Just to see if its in working order.

KOT
 

·
Registered
06 CTS-V
Joined
·
20 Posts
Discussion Starter #15
So I just ordered the DRL module at my local dealer and hopefully it works as it was $80 and no returns, I'll report back once i try it out.

Does anyone have any wiring diagrams available? I may have to rig up an independent switch in the interim until this problem can be solved.
 

·
Registered
06 CTS-V
Joined
·
20 Posts
Discussion Starter #18
This was in the link that I provided.



KOT

Thanks, Sorry i meant for the actual car's harness, My mechanic said that he could hook up an independent switch to temporarily trigger the parking lights as he's not seeing a control signal at the parking light relay.


I noticed also last night, when i unlock the car the lights on the dashboard (cluster) flash as they always did. its almost like the signal just isn't being seen outside of the car.
 

·
Registered
06 CTS-V
Joined
·
20 Posts
Discussion Starter #19
So,

Installed the DRL module from the dealer, unfortunately still nothing. Also tried re-installing the factory nav unit, that didn't help either.

Yesterday, my mechanic used his scan tool, and there were no faults, any ideas what i should check next?

I haven't asked this in the V-Forum, I didn't think i should crosspost.
 

·
Registered
06 CTS Sport/Luxury package
Joined
·
9,802 Posts
Go a head and post a thread over in the V section. Just briefly explain what is going on and attach a link to this thread for more details.

Perhaps someone could be of better assistance. And instead of re-typing, just link.

KOT
 
1 - 20 of 27 Posts
Top