Cadillac Owners Forum banner

1 - 2 of 2 Posts

·
Registered
07 STS, 03 Deville, Past '01' Seville, '96' Deville, '87' Deville, '95' ElDo
Joined
·
30 Posts
Discussion Starter #1 (Edited)
96 DeVille I am still having cluster fuse problems .... it blows at random.. I can't find the problem... am I wrong in thinking that the cluster controls some relays in the car.... if so, I believe that I have a faulty relay or a faulty cluster... strange things happen when the fuse is blown... trunk and gas door, A/C compressor, and many things does not work and some things do.... when the fuse is about to blow the back interior lights flash.. ... also my radio sound goes off and on at random, have checked the power on the amp and the power is there... the radio headunit is still showing on, when sound is down and the seek control is working, the tape player is running... have another radio,, changed it out ... same problem... wondering how many sources of power is supplied to the radio thru the 32 pin interface connector... when the sound is off the antenna stills operates and other features operate from the head unit.. I have a IP1740 and a IP1771 code.... the radio is a bose head and an active audio amp .... works fine when the sound is on.... when I bought the car about a month ago the radio, the headunit, was replaced with a third party radio and I changed it back to the OEM radio headunit. I don't have much hair left to pull out..... somebody give me some insight.
 

·
Registered
2007 EXT Supercharged
Joined
·
1,497 Posts
id say its possessed,

actually with the radio, from other posts ive read, the head unit is in the truck or something, and the dash just has the tuner part in it.
 
1 - 2 of 2 Posts
Top