Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
The parking brake doesn't fully disengage when you put the car in gear.
You can hear it pop, but the light stays on until you lift the petal up with your foot.
Anything I should look for/or replace?
 

·
Registered
2005 Escalade 6.0L 2WD, 2007 Jeep Grand Cherokee Limited CRD
Joined
·
3,726 Posts
There is a return spring that has probably broken. My '94 Deville does the same thing, I just haven't gotten around to replacing the spring. My old '94 Deville Concours had the same problem! One day I was sitting in the car, and the spring sprung and flew off! Must be a common failure for those!
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
87,179 Posts
I think a more common failure is corrosion inside the parking brake cables. If moisture gets inside the cable housing it causes the cable to rust. At some point it will get bad enough that it simply will not release at all. Inspect it closely from front to rear. The only real fix is to replace the offending cable.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #4
Thanks, sounds like I need to get underneath..
 

·
Registered
Joined
·
4 Posts
Had the same problem a few months ago. I neglected it for a couple weeks and continued pushing the lever up with my foot to disengage the P brake, but it eventually worsened until the rear brakes seized entirely. The problem was not the cable or the spring. Fixed it by replacing both rear brakes almost in their entirety.
 
1 - 5 of 5 Posts
Top