Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
STS - V
Joined
·
13 Posts
Discussion Starter #1
codes, codes, and more codes

I just had a bunch of codes pop up on my 2008 STS-v

C0561- system disabled (abs)
c 0253 - steering wheel alinement sensor
My left front and right rear wheel speed sensors
no centering information
all four of these came via a scan tool (clearly)

My traction, abs and stability warning light read outs across the DIC

I checked out some older threads and found that 1 guy was having a similar issue - he replaced the wss on his right rear and that did not fix the problem - then replaced the steering wheel, said that fixed problem.


Has anyone else found themselves in the same boat? I thinking about starting with the steering wheel. Has anyone replaced this sensor? how hard is it? can you aline the steering wheel after you've got it all back together or is it an alinement shop issue?


thanks in advance for any info

also has anyone used the online service manuals - 30 bucks a year seems to good to be true and a much better deal then hundreds spent on the paper copy, hows the content?
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
68,449 Posts
I use Alldata for the Seville and 2 Ford trucks. Works well - they're the GM/Helm factory manuals plus a LOT more - labor times, old parts pricing, all Technical Service Bulletins, all RPOs, tech hints - more. Plus it's updated. The paper GM manuals are not.

You can computer copy/print the diagrams, connector pinouts and wiring schematics.
 

·
Registered
Sts-v 2008
Joined
·
139 Posts
I didn't have your exact systems but the wheel speed sensor started to fail and caused all kinds of other codes and warnings to popup. Mechanic said lets replace the wheel bearing as that will need to be done if the speed sensor has failed. After they replaced bearing all the other code have clear and not come back. Just my experience with my car your mileage may very.
 

·
Registered
STS - V
Joined
·
13 Posts
Discussion Starter #4
Just an update. I've replaced the front bearing but also need to do the rear but it seems like that will fix all problems (all lights went temporarily).
 
1 - 4 of 4 Posts
Top