Cadillac Owners Forum banner

1 - 7 of 7 Posts

·
Registered
2007 DTS
Joined
·
16 Posts
Discussion Starter #1
I have an 07 DTS, about 80,000 miles. I attempted to start it recently at night and it was completely dead, as if the battery was unhooked. I eventually turned the light switch from auto to on and everything came back to life and the car started normally. The dealer had no idea what caused it. Any help??
 

·
Registered
2006 DTS
Joined
·
83 Posts
Also check the ground connection to the floorboard/frame under the rear seat where the battery is located (loosen and re-tighten). Also a possibility that I recently ran into could be the key itself. I have an 06 and it had gotten to where when you got into the car using the original key, you would need to put the key into the ignition and then buckle your belt (3-4 secs) kill time, etc. before trying to start the car. If you didn't wait this 3-4 seconds or more it would only click, the display would go black, etc. (typical symptoms of a dead or dying battery). It was the theft control protection not recognizing the key. However, if you waited a few seconds for the key to energize and transmit itself to the computer it would always start fine. This annoyed me so I went and got a brand new key (with a new transponder inside) and now it no longer has that problem. Just an idea if you still use have the original keys. They do weaken over time.
 

·
Registered
2007 DTS
Joined
·
16 Posts
Discussion Starter #4
Thanks, I'll check the connection and if it does it again, I'll get another key.

----------

I checked it and everything was tight. Thanks.
 

·
Registered
2008 DTS
Joined
·
1 Posts
I need help! I have an 2008 DTS with 82k I bought last week. Car was running great up until Wednesday when I went to start it with the remote start and all it did was crank... Tried it with the key and it did the same. Had it towed to the Hyundai dealership where I bought it from and where I am a manager, let it sit for a day and it started fine for a day, but today it did the same thing... Any ideas?
 

·
Registered
2007 DTS
Joined
·
16 Posts
Discussion Starter #7
Had the same issue again recently. I turned the light switch to the off position to turn the lights off rather than let them time off. After sitting awhile, I attempted to start the car and everything was dead. I turned the light switch to the on position and everything came back to life and the car started normally. Anyone had this issue?
 
1 - 7 of 7 Posts
Top