Cadillac Owners Forum banner

1 - 13 of 13 Posts

·
Registered
2006 Escalade AWD
Joined
·
58 Posts
Discussion Starter #1
I replaced my starter when I first bought my truck. That was about a year and a half ago. We all know what kind of a winter we've had this year. But when I went to start my truck this morning, I got nothing but a click. Battery is still full juice. Seems awfully soon to have to replace the starter again?
 

·
Registered
08 Escalade ESV awd, 05 Yukon Xl Denali awd, 06 SRX sold
Joined
·
1,852 Posts
raviel119 said:
I replaced my starter when I first bought my truck. That was about a year and a half ago. We all know what kind of a winter we've had this year. But when I went to start my truck this morning, I got nothing but a click. Battery is still full juice. Seems awfully soon to have to replace the starter again?
it could be the starter most are remanufactured, how are you verifying the battery voltage which i am leaning more toward
 

·
Registered
03 cadillac escalade
Joined
·
11,902 Posts
Could very likely be a bad cell in the battery

Winter is hard on batteries and can cause hard or no start conditions if the battery is weak or has a bad cell
 

·
Registered
2006 Escalade AWD
Joined
·
58 Posts
Discussion Starter #6
I replaced my battery a couple of days apart from replacing the starter in late October of 13. The guy who towed my truck said the battery was fine. He checked using a handheld device. All the lights and radio, Windows roll down fine. Just when I turn the key it makes a click. The lights on the dash stay on with every turn. I'm just amazed that if it is my starter, how it can go bad this quick.
 

·
Registered
03 cadillac escalade
Joined
·
11,902 Posts
Check the battery cables
I have had this issue with my car when I disconnect the battery while I ain't running it or working in it

They should be snug and shouldn't move
 

·
Registered
2006 Escalade AWD
Joined
·
58 Posts
Discussion Starter #9
So after checking the cables the starter definitely was the culprit. Part changed and I'm ready to rock. It just amazes me how these electrical parts are hit or miss. You can buy a rebuilt one and it last longer than a brand new one. Or visa versa. It's almost all a shot in the dark. Thanks guys for you help as usual. At least I know the other stuff is good.
 

·
Registered
96 Eldorado
Joined
·
2 Posts
Good morning, quick check....Turn headlight on, see how bright they are.. If they are low or not bright at all... Then have someone try to start the truck, if light go out starter is not receiving enough voltage....

2. Now raise hood and grab the ground cable on your battery and pull hard, Have someone try to start again.... Be careful I bet it starts but if not, pull the Positive cable and repeat trying to start while pulling hard on it.... I think it is probably running.... If so you have bad connection, if not the battery is dead and needs recharge.... Once recharged it shall start but you now need to know if its charging, a different problem if you need help, just ask.... Peace of cake.... Rogerdog ( find the problem before we spend one dime)
 

·
Registered
03 cadillac escalade
Joined
·
11,902 Posts
Rogerdog That headlight trick only works if you have the high beams on if you have a 03+

The 02's was the last year for halogen headlights
Otherwise it will work
 

·
Registered
2007 STS-V, 2007 Escalade, 2003 Escalade EXT, 2014 ELR
Joined
·
825 Posts
it could be the starter most are remanufactured, how are you verifying the battery voltage which i am leaning more toward
I've had bad luck with reman parts on my vehicles. You gotta love lifetime warranty, just means they'll give you new ones and you get to change them out over and over again.

The alternator and starter on my 05 are not OEM but I think they are OEM manufacturers for GM. My starter is the Advance Auto box brand and the box states it is new, not remanufactured. It does have AC DELCO cast into the housing though and it didn't look to be a used housing as is the case with most reman parts I've used in the past. Its been working good though for the last couple of years.

To the OP, when my original starter went bad I think it had a soft short in it. It would kill the battery in a single day and took me awhile to figure it out. Changed the starter and never had a dead battery again.
 

·
Registered
2006 Escalade AWD
Joined
·
58 Posts
Discussion Starter #13
I've had bad luck with reman parts on my vehicles. You gotta love lifetime warranty, just means they'll give you new ones and you get to change them out over and over again.

The alternator and starter on my 05 are not OEM but I think they are OEM manufacturers for GM. My starter is the Advance Auto box brand and the box states it is new, not remanufactured. It does have AC DELCO cast into the housing though and it didn't look to be a used housing as is the case with most reman parts I've used in the past. Its been working good though for the last couple of years.

To the OP, when my original starter went bad I think it had a soft short in it. It would kill the battery in a single day and took me awhile to figure it out. Changed the starter and never had a dead battery again.
Very good to know wake.
 
1 - 13 of 13 Posts
Top