Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Just purchased so have no history.
Turn key to on everything lights up (notice the gas gauge reads empty)
Turn further to "start" nothing happens.
Jumper across the starter relay (actually the relay has it's case removed so you can push the contacts closed so the engine turns over)
Engine starts.
Go back to key and turn off the engine.
Turn key back on and to start. Engine starts right up. The gas guage also works. You can shut of and restart as many times as you want. EXCEPT
If you wait some amount of time (I haven't figured it out yet) You have to do the "initialization" again.
Any ideas would be appreciated.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #2
Just purchased so have no history.
Turn key to on everything lights up (notice the gas gauge reads empty)
Turn further to "start" nothing happens.
Jumper across the starter relay (actually the relay has it's case removed so you can push the contacts closed so the engine turns over)
Engine starts.
Go back to key and turn off the engine.
Turn key back on and to start. Engine starts right up. The gas guage also works. You can shut of and restart as many times as you want. EXCEPT
If you wait some amount of time (I haven't figured it out yet) You have to do the "initialization" again.
Any ideas would be appreciated.
Anyone seen or heard of this before?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Well I hate it when I read a thread that address the same problem I have and it just ends, many times without clear information as to what fixed the problem. So I share the following. I purchased the theft deterrent module which is around the ignition key area. You have to pull off some of the covers. I got the module from ebay used. I tried the 3 step 30 minute relearn procedure a few times and it didn't fix the problem. At the recomendation of Just Answer teck I purchased a new key. Brought it home and tried 3 times the 30 minute relearn. The first 2 times I was not sure I made each step right, so I tried one more time, even sat in the car reading my emails etc so that I could observe the lock tell going out after about 10 minutes. By the way at the end of each of the first 2 10 minute cycles I pulled the key out. At the end of the third 10 minutes I left the key in, turned it to off, then on, then start, and bingo it worked. Hope anyone with simular problem will benifit by this post.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Well I hate it when I read a thread that address the same problem I have and it just ends, many times without clear information as to what fixed the problem. So I share the following. I purchased the theft deterrent module which is around the ignition key area. You have to pull off some of the covers. I got the module from ebay used. I tried the 3 step 30 minute relearn procedure a few times and it didn't fix the problem. At the recomendation of Just Answer teck I purchased a new key. Brought it home and tried 3 times the 30 minute relearn. The first 2 times I was not sure I made each step right, so I tried one more time, even sat in the car reading my emails etc so that I could observe the lock tell going out after about 10 minutes. By the way at the end of each of the first 2 10 minute cycles I pulled the key out. At the end of the third 10 minutes I left the key in, turned it to off, then on, then start, and bingo it worked. Hope anyone with simular problem will benifit by this post.
So I need to give an update. The above seemed to work, but seems it only lasted for one start, the the original problem came back. Soooo I bought a used ECM (the one that mounts to the front right of engine). It showed up today and I installed it. Did the learn procedure (3 times on for 10 minutes each) and the car now starts normally. I tried it multiple times after multiple delays between starts. I then did the learn procedure on the second key, and again it seems to now be working. I will be taking it to a dealer to have the vin and mileage programed into the ECM early next week. I will then need to drive it for awhile so the computer records all the proper information for a smog test.
 
1 - 5 of 5 Posts
Top