Cadillac Owners Forum banner

1 - 3 of 3 Posts

·
Registered
2010 CTS Wagon
Joined
·
214 Posts
Discussion Starter #1
Hi all:

While going down a long hill with a speed limit of 25 mph (I was at about 30 or so), I felt like a buzzing in the brake pedal, and all of a sudden all sorts of DIC warnings go off: AWD off; service Stabiltrack; Service brake assist; and one more associated with the Stabiltrak. I drove it to the dealer with no issues, and they were able to get me in quickly. They will tell me the issue tomorrow. I just got it back from replacing the real driver's side wheel bearing hub and had the 4 brake rotors resurfaced; and the 90K miles service. I suspect it is a wheel bearing sensor that got disconnected or similar which resulted in the stabiltrak warnings. Any other thoughts? Dealer has been excellent in service so far, and treated me well. I will probably buy next car from them.

BTW, 2010 AWD CTS Wagon, Premium, 90K miles

Thanks
 

·
Registered
'14 CTS-V LongRoof; '16 ATS-V Sedan,' 04 Trailblazer 4x4; '10 CTS LongRoof gone but never forgotten
Joined
·
14,145 Posts
You're on track.

There have been quite a few posts on this very topic.
 

·
Registered
2010 CTS Wagon
Joined
·
214 Posts
Discussion Starter #3
Revised to indicate the problem....Talked to dealer. The issues are two sensors not communicating with computer. These two sensors are in the from. Both front wheel hubs need to be removed and sensors replaced. $700. I ask the question, since two sensors not communicating and failure happened at same time, what about the computer it is talking with? Wouldn't that be more likely the cause than the sensors failing? Nope it is the sensors....so go ahead and get 2 $40 senors replaced with all the labor 6$683 total. I get a call this afternoon... "the sensors cured the stabilitrak issue, but we are getting ABS warnings (I think that was the "service brake assist" warning I got") - it needs a new ECM module, and would be $993 more - total $1700. I just paid $1700 in repairs last week. I had a real driver's side hub go. I also had brake rotors replaced. No major warranty issues in 90K miles, and since warranty expired 3 weeks ago, close to $4000 in repairs.

I hope this is not going to turn out as bad as my two Mercedes Benz. I am a bit aggravated. Up until now it has been reliable, but it hasn't stranded me yet...
 
1 - 3 of 3 Posts
Top